
4 ANALIZA VEKTORSKIH PODATAKA 

Cilj ove vežbe je sticanje znanja i veština kada je reč o korišćenju prostornih operacija nad 

vektorskim podacima u softverskom okruženju QGIS. Konkretno, za rešavanje postavljenog 

zadatka biće korišćene sledeće operacije:  

 kreiranje bafer zona; 

 presecanje vektorskih slojeva; 

 prostorno pridruživanje i agregacija vrednosti; 

 dodavanje geometrijskih kolona entitetima; 

 izvoz podataka u geoprostornu bazu podataka; 

Za izradu ove vežbe pretpostavlja se da je student savladao osnove korišćenja softvera QGIS i 

materiju iz prethodnih vežbi. Pre rada, preporučuje se čitaocu da pročita bar neka od sledećih 

poglavlja iz publikacije QGIS User Guide: 

 Managing Data Source; 

 Working with Vector Data; 

 QGIS processing framework (Introduction, Vector menu, The toolbox). 

Pored toga, predlaže se i čitanje poglavlja Vector Spatial Analysis (Buffers) iz publikacije A 

Gentle Introduction to GIS (Sutton et al. 2009). 

4.1 Tekst zadatka 

Za potrebe planiranja trase autoputa formirati bafer (pojas) širine 50m kako bi se utvrdilo koliko 

ukupno zgrada upada u zonu oko trase. Izvršiti presecanje dobijenog bafera i zgrada, ako i 

https://docs.qgis.org/3.16/pdf/en/QGIS-3.16-DesktopUserGuide-en.pdf


prostorno pridruživanje zgrada baferu radi potrebnih analiza. Analizirati koja je najveća zgrada 

koja  upada u zadati pojas. 

4.2 Podaci neophodni za izradu zadatka 

Podaci neophodni za izradu zadatka dati su u odgovarajućoj pratećoj ZIP datoteci, i to su: 

 Trasa prve faze autoputa data u DXF formatu u EPSG:6316 koordinatnom sistemu; 

 Podaci o zgradama Beograda preuzeti sa OSM mapa u vidu Shapefile podataka u 

EPSG:4326 koordinatnom sistemu, 

 GoogleMaps kao rasterska podloga. 

4.3 Postupak izrade 

Korak 1: Pokretanje QGIS-a 

Pokrenuti QGIS softverski paket dvoklikom na odgovarajuću ikonicu. Ukoliko ikonica nije 

kreirana na radnoj površini računara (engl. Desktop), program se može pokrenuti i sa lokacije 

gde je instaliran. Po podrazumevanim podešavanjima, izvršna datoteka će se nalaziti na putanji 

"C:\Program Files\QGIS 3.16\bin". Potrebno je sačuvati QGIS projekat, što se vrši opcijom 

Project → Save as, gde je potrebno definisati lokaciju na računaru gde će projekat biti sačuvan i 

njegovo ime („ImePrezime_VektorskeAnalize.qgs“). 

 

Korak 2: Učitavanje ulaznih podataka  

Za učitavanje ulaznih podataka u radni prostor QGIS-a koristi se komanda Layer → Add Layer 

→ Add Vector Layer pošto se radi o podacima u vektorskom formatu. DXF i Shapefile (.SHP) 

Napomena: 

Za sve podatke koji će biti korišćeni u ovom primeru potrebno je definisati 

parametre projekcije date predefinisanim koordinatnim sistemom (CRS) MGI 

Balkans zone 7 (EPSG:6316). Obavezno podesiti da u delu Project → Project 

Properties → CRS, opcija No CRS  bude nečekirana. 



tipovi podataka se učitavaju na ovaj način. QGIS ne podržava DWG format iz AutoCAD-a tako 

da je najbolje slojeve čuvati u vidu DXF fajlova. 

Nakon učitavanja podataka, potrebno je podesiti koordinatni sistem. Ovaj dijalog će najčešće biti 

automatski pokrenut prilikom učitavanja podataka u QGIS, a u slučaju da se to ne desi, 

projekciju definisati pomoću popup menija (dobija se klikom na desni taster miša kada je kursor 

iznad imena sloja) i aktiviranjem opcije Layer CRS → Set Layer CRS... Budući da su ulazni 

podaci različitih parametara projekcije, bilo bi dobro da se svi vektorski podaci sačuvaju u 

jedinstvenom koordinatnom sistemu Balkans Zone 7 - EPSG (6316) sa komandom desni klik na 

vektorski sloj pa Export → Save Features as. Reprojekcija vektorskih podataka se može vršiti i 

sa komandom Vector → Data Management Tools → Reproject Vector. 

Korak 3: Kreiranje bafera oko trase autoputa 

U ovom koraku vrši se kreiranje bafer zone oko novoprojektovane trase autoputa na odstojanju 

od 50 metara u skladu sa tekstom zadatka. Za definisanje bafer zone koristi se opcija Vector → 

Geoprocessing Tools → Buffer. Pored ove opcije, postoji i srodna opcija Variable width buffer 

koja se koristi kada je potrebno definisati bafer zonu različite širine za različite entitete. Tada se 

za vrednost odstojanja uzima M vrednost koja predstavlja najčešće temporalnu dimenziju nekog 

entiteta (pored prostornih koordinata X,Y i Z). 

U prozoru za podešavanje parametara bafera potrebno je podesiti ulaznu datoteku nad kojom se 

kreira bafer (Input layer), vrednost odstojanja (Distance) i izlazna datoteka (Buffer). Ukoliko se 

označi kućica Open output file after running algorithm, rezultujući sloj će automatski biti učitan 

u tekući projekat. Uneti 50 za vrednost pojasa oko trase, ostavitI uključenu opciju Dissolve result 

da bi sloj bio stopljen u vidu jednog poligona bafera, a ostala podešavanja ostaviti na 

podrazumevanim vrednostima (Slika 4.1). Dobijenom sloju potrebno je podesiti odgovarajući 

koordinatni sistem. Vektorskom sloju dodeliti naziv ImePrezime_BaferTrase klikom na dugme 

sa tri tačke u delu Buffered i opcijom Save to GeoPackage... sloj se čuva u okviru novokreirane 

GeoPackage geoprostorne baze podataka ImePrezime_Procesiranje.gpkg. 



 

Slika 4.1. Parametri kreiranja bafera oko trase autoputa 

Kao podlogu učitati i GoogleMaps sloj korišćenjem XYZ Tiles načina učitavanja u QGIS 

Browser-u. 

Korak 4: Učitavanje podataka o zgradama  

Podatke OSM mapa moguće je odjednom preuzeti za sve vektorske slojeve preko web sajta 

geofabrik.de. Ali ovi podaci zauzmaju dosta memorije i korisniku sigurno ne trebaju svi dostupni 

vektorski slojevi ovog skupa podataka. Zato je u QGIS-u moguće preuzeti manji set podataka 

jednog tipa vektorskog sloja i za određenu geografsku lokaciju korišćenjem plugina QuickOSM. 

Plugin pronaći i instalirati korišćenjem komande Plugins → Manage and Install Plugins. 

Navedeni plugin će se pojaviti u meniju Vector. Otvoriti funkciju i odabrati podatke filtriranja 

kao na sledećoj slici pri čemu posle toga izvršiti uklanjanje vektorskih slojeva koji nisu poligoni. 

Takođe podaci koji su učitani korišćenjem QuickOSM plugin-a treba da se sačuvaju u projekciji 

EPSG:6316 (Export → Save Features as i može se odabrati tip podatka Shapefile ili da se čuvaju 

u okviru već kreirane GeoPackage baze podataka). 



 

Slika 4.2. Učitavanje OSM podataka o zgradama za područje Beograda 

Ukoliko ide sporo učitavanje vektorskog sadržaja preko QuickOSM-a preporučuje se uvoz 

vektorskog fajla gis_osm_buildings_a_free_1.shp koji je preuzet sa sajta 

http://download.geofabrik.de/europe/serbia.html. Tu se nalaze svi podaci koje je potrebno 

obrisati tako da ostanu samo poligoni zgrada (Slika 4.3). Ovo se naravno preuzima komandom 

Layer → Add Layer → Add Vector Layer gde se pokaže na fajl gis_osm_buildings_a_free_1.shp. 

Uglavnom bolje je raditi sa podacima sačuvanim na lokalnoj mašini ukoliko ih je potrebno 

editovati ili učestvuju u analizama. Ako je potrebno da se podaci pojave kao referentna podloga 

za npr. digitalizaciju, tada se mogu povlačiti sa web-a ukoliko je jaka internet konekcija. 

http://download.geofabrik.de/europe/serbia.html


 

Slika 4.3. Učitavanje OSM podataka o zgradama (crveni poligoni) za područje Beograda 

Ukoliko su učitani podaci o zgradama iz fajla gis_osm_buildings_a_free_1.shp, da bi se pravilno 

izvršile prostorne operacije sa vektorskim slojevima, potrebno je sačuvati sve podatke pod istim 

parametrima projekcije – EPSG 6316 (Slika 4.4). 

 

Slika 4.4. Čuvanje poligona zgrada u vidu Shapefile sa EPSG:6316 parametrima projekcije 



Korak 4: Isecanje delova zgrada u zoni pojasa oko trase autoputa  

Kako bi se identifikovali delovi zgrada koji upadaju u pojas oko trase autoputa potrebno je 

izvršiti presecanje sloja bafera sa poligonima zgrada. Pre ovoga potrebno je odrediti i površine 

celih poligona zgrada, ako ne postoje među atributima, tako što će se izvršiti sličan postupak kao 

i na Error! Reference source not found. pri čemu se za to polje računa $area (Slika 4.5). 

 

Slika 4.5. Kreiranje novog atributa sa vrednostima površina poligona zgrada 

Presecanje slojeva se vrši pokretanjem komande Vector → Geoprocessing Tools → Intersection. 

Redosled slojeva prilikom presecanja (preklapanja) dva sloja nije strogo definisan pošto važi 

svojstvo komutativnosti (𝐴 ∩ 𝐵 = 𝐵 ∩ 𝐴),ali je u konkretnom slučaju pravilnije i smislenije da 

se vrši presecanje sloja „Zgrade“ slojem „Bafer50“. Izlaznu datoteku sačuvati u odabirom 

geprostorne baze podataka (klikom na dugme ... u delu Intersection i odabirom opcije 

GeoPackage, pa onda na već postojeći fajl ImePrezime_Geoprocesiranje.gpkg) treba dodeliti 

naziv ImePrezime _PresekBuferaIZgrada (Slika 4.6). 



 

Slika 4.6. Presecanje lejera poligona zgrada sa formiranim baferom trase 

Ovde se može podesiti i koji će se sve atributi prikazivati u rezultujućem sloju klikom na dugme 

sa tri tačke u delu Input i Overlay fields i odabirom naziva atributa koji treba da se zadrže. 

Nakon presecanja dobija se rezultujući sloj sa delovima zgrada koje upadaju u bafer sa 

atributima koji su sadržani u oba vektorska sloja. Da bi videli kolike su nove površine dobijene 

presecanjem i koliko procentualno je površina zgrade umanjena nakon presecanja, sračunaćemo 

nove površine pokretanjem Field Calculator-a. 



 

Slika 4.7. Kreiranje novog atributa sa vrednostima površina isečenih poligona zgrada 

Računanje novog atributa sa vrednostima procentualnog smanjenja površina zgrada vrši se isto 

pomoću Field Calculator-a (Slika 4.8). 

 



 

Slika 4.8. Kreiranje novog atributa sa vrednostima procentualnog smanjenja površina zgrada 

Ukoliko je potrebno odrediti maksimalnu površinu zgrade koja se nalazi u baferu trase autoputa, 

moguće je sortirati vrednosti atributa klikom na naziv kolone u Attribute Table, a moguće je i 

odrediti vrednost korišćenjem plugin-a Group Stats. Navedeni plugin se instalira na uobičajen 

način (Slika 4.9) a pojavljuje se u meniju Vector. Srednja vrednost i druge statistike se mogu 

odrediti korišćenjem ovog plugin-a (Slika 4.10). 



 

Slika 4.9. Instalacija plugin-a GroupStats 

Potrebno je u polje Value prevući naziv atributa a u polje Columns statistiku koja treba da se 

sračuna (Slika 4.10). 

 



 

Slika 4.10. Određivanje maksimalne površine zgrade koja se nalazi u baferu trase autoputa 

 

Korak 5: Ekstrakcija zgrada (selekcija) koje u celosti upadaju u zonu pojasa oko trase 

autoputa  

Ukoliko je potrebno sačuvati cele poligone zgrada ili gledati da li te zgrade u celosti pripadaju 

bafer-u, moguće je koristiti komandu Extract by Location koja se nalazi u grupi komandi Vector 

selection Processing Toolbox-a (Slika 4.11). 



 

Slika 4.11. Pokretanje funkcije Extract by Location 

Kod ove funkcije se može birati više opcija odnosa između entiteta u dva sloja, kao npr. da li se 

dodiruju, seku, sadrže i dr. (Slika 4.12). Rezultat zgrada koje se u potpunosti nalaze u baferu 

trase jeste opcija are within (Slika 4.13). Isprobati druge opcije navedenog upita. 

 
Slika 4.12. Parametri funkcije Extract by Location 



 

Slika 4.13. Rezultat funkcije Extract by Location (zeleni poligoni) 

Korak 6: Prostorno pridruživanje zgrada zoni pojasa oko trase autoputa 

Prostorno pridruživanje jeste prostorna analiza gde se na osnovu lokacije mogu agregirati atributi 

entiteta jednog lejera koji su u nekom odnosu sa entitetom drugog lejera. Funkcija Join attributes 

by location (summary) se nalazi u grupi komandi Vector general Processing Toolbox-a. 

Ovde se može izvršiti određivanje ukupnog broja zgrada koje upadaju u bafer trase, suma svih 

površina zgrada, prosečna površina zgrada koje upadaju u bafer trase itd. Bitno je da se prvo 

odabere sloj u okviru koga je bafer a zatim zgrade od kojih će se agregirati vrednosti atributa 

(Slika 4.14). 



 

Slika 4.14. Parametri funkcije Join attributes by location (summary) 

Moguće je zadati po kojim atributima će se vršiti proračun – klikom na dugme sa tri tačke kod 

Fields to summarise (npr. samo površine zgrada) i koje će se sve statistike određivati - klikom na 

dugme sa tri tačke kod Summaries to calculate (Slika 4.15). Isto se može izabrati postojeća 

geoprostorna baza podataka ImePrezime_Procesiranje.gpkg gde se može ovaj rezultat sačuvati 

kao novi sloj SumarizacijaZgradauBaferu50. 

Kao rezultat se dobija nov sloj koji sadrži novogenerisane atribute sa sumarizacijom vrednosti 

atributa po pojedinim statistikama (Slika 4.16). 



 

Slika 4.15. Izbor statistika koje se mogu sračunati nad vrednostima atributa koji se agregiraju 

 

Slika 4.16. Rezultat pridruživanja zgrada baferu 

 

 

Dodatni zadatak: 

Proučiti i isprobati još neke funkcije koje se nalaze u meniju Vector (naročito one 

koje se nalaze u podmenijima Geoprocessing Tools, Geometry Tools i Data 

Management Tools)! 

 


