
2 POČETAK RADA SA QGIS SOFTVEROM 

Cilj ove vežbe je upoznavanje sa korisničkim interfejsom softvera QGIS i izvođenje 

najjednostavnijih operacija u radu sa prostornim podacima, kao što je učitavanje prostornih 

podataka u rasterskom i vektorskom obliku i podešavanje osnovnih parametara za prikaz tih 

podataka u okruženju softvera.  

Pre rada, preporučuje se čitaocu da pročita bar neka od sledećih poglavlja iz publikacije QGIS 

User Guide (QGIS Development Team 2017): 

 Getting Started, 

 QGIS GUI, 

 General Tools, 

 QGIS Configuration, 

 Working with Projections, 

 Managing Data Source, 

 Working with Vector Data (The Vector Properties Dialog), 

 Working with Raster Data (Raster Properties Dialog). 

2.1 Tekst zadatka 

Kreirati novi QGIS projekat i u njega učitati obezbeđene geoprostorne podatke: satelitske, avio i 

UAV ortofoto snimke, katastarske planove, digitalni model terena, poligone države i opština, 

zgrade, puteve, železnice, vodotoci, katastarske parcele i druge raspoložive podatke. Definisati 

parametre projekta da bude MGI 1901 / Balkans zone 7 (EPSG:6316). Prikazati na ekranu u 

okviru jedne karte sve učitane slojeve. Izvršiti stilizaciju slojeva, tako da budu prikazane samo 

ivične konture opština sa oznakama, dok unutrašnjost treba da bude transparentna. Zgrade 

http://docs.qgis.org/2.18/pdf/en/QGIS-2.18-UserGuide-en.pdf


prikazati drugačije obojene u zavisnosti od tipa zgrade, prikazati nazive vodotokova. Prikazati 

zgradu supermarketa sa obuhvatom učitanih slojeva u razmeri 1:2000 i sačuvati kartu kao sliku u 

JPEG formatu. Izvršiti pretragu zgrada preko atributa type radi pronalaska supermarketa. 

2.2 Podaci neophodni za izradu zadatka 

Podaci neophodni za izradu zadatka dati su u folderu uz ovu vežbu na veb sajtu egeo.grf.bg.ac.rs 

za ovu vežbu i to su: 

 RGB ortofoto sastavljen na osnovu satelitskih snimaka misije Sentinel-2 prostorne 

rezolucije 10m za veći deo područja Republike Srbije u rasterskom JPEG2000 formatu, 

 RGB ortofotoi sastavljeni na osnovu avio i UAV snimanja više prostorne rezolucije za 

područje naselja Umka u rasterskom GeoTIFF i JPG formatu, 

 Podaci DKP-a u vidu parcela, zgrada  kao delova parcela, graničnih linija itd. u ESRI 

Shapefile formatu, 

 Poligoni države i pripadajućih opština dati u GeoPackage prostornoj bazi podataka, 

 Katastarski planovi dati u rasterskom ECW formatu, 

 DMT predstava visina terena data u rasterskom GeoTIFF formatu; 

 Vektorski podaci o zgradama, putevima, železnicama, vodama, vodotocima i dr. 

dostupni iz OSM podataka dati u ESRI Shapefile formatu, 

 Ortofoto visoke rezolucije dostupnom putem WMS-a. 

 Rasterske podloge kao što su Google i OpenStreet mape. 

2.3 Postupak izrade 

Korak 1: Pokretanje QGIS-a 

Pokrenuti QGIS softverski paket dvoklikom na odgovarajuću ikonicu. Ukoliko ikonica nije 

kreirana na radnoj površini računara (engl. Desktop), program se može pokrenuti i sa lokacije 

gde je instaliran. Po podrazumevanim podešavanjima, izvršna datoteka će se nalaziti na putanji 

"C:\Program Files\QGIS 3.16\bin". Nakon što je pokrenuta aplikacija napraviti novi projekat 

klikom na ikonicu New Project  i sačuvati isti klikom na ikonicu Save Project . Projektu 

dati naziv Pocetak_QGIS. Klikom na dugme Save sačuvaće se navedeni fajl u željenom folderu 

sa ekstenzijom .qgz. 

http://egeo.grf.bg.ac.rs/mod/folder/view.php?id=196


Korak 2: Definisanje parametara projekcije projekta 

Pre učitavanja bilo kojih prostornih podataka u radno okruženje QGIS-a, poželjno je podesiti da 

se prilikom uvoza zahteva definisanje ili odabir parametara projekcije prostornih podataka. Ovo 

se vrši tako što se za opciju Settings → Options odabere kartica CRS i u delu CRS for layers 

štiklira opcija Prompt for CRS (Slika 2-1). Na ovaj način će se prilikom učitavanja podataka 

automatski otvarati prozor za dodeljivanje projekcije podacima i korisnik neće imati problema sa 

reprojekcijom između koordinatnih sistema (OTF – On The Fly Transformation koji se 

pojavljuje u donjem desnom uglu statusne linije). Ukoliko korisnik zna u kom koordinatnom 

sistemu će raditi može odmah definisati ili odabrati parametre projekcije projekta u delu Default 

CRS for new projects (u ovom slučaju je odabran je EPSG: 6316 – MGI 1901 / Balkans zone 7 - 

Slika 2-1). Promena parametara projekcije projekta vrši se klikom i u desni ugao statusne linije 

na ikonicu Current CRS . 

 

Slika 2-1. Podešavanja za izbor parametara projekcije projekta 

Korak 3: Učitavanje podataka digitalnog katastarskog plana (DKP) 

Digitalni katastarski plan se sastoji iz više lejera različitog tipa geometrije kao što su poligoni, 

linije i tačke. Ovde su dostupne parcele, međne linije i prelomne tačke koje se kao vektorski 

podaci mogu učitati u QGIS pokretanjem komande Layer → Add Layer → Add Vector Layer. 

Nakon pokretanja funkcije, od korisnika se zahteva da pokaže putanju do vektorskih datoteka 

koje želi da učita klikom na dugme  u delu Source. Kako su ovi vektorski podaci dati u vidu 

ESRI Shapefile datoteka, za ekstenziju datoteke odabrati ESRI Shapefiles i izvršiti selekciju svih 

datoteka u folderu DKP. 



 

Slika 2-2. Učitavanje vektorskih podataka DKP-a 

Nakon učitavanja navedenih slojeva aktivirati komandu Identify Features  i kliknuti na 

nekoliko entiteta (pri čemu je navedeni lejer sa entitetima označen u spisku entiteta). 

Korak 4: Učitavanje listova digitalnog ortofotoa satelitskih snimaka 

Listovi digitalnog ortofotoa predstavljaju karakteristične rasterske podatke. Učitavanje rasterskih 

tipova podataka vrši se funkcijom koja se poziva iz menija Layer → Add Layer → Add Raster 

Layer. Ovim se pokreće dijalog Data Source Manager u okviru kog se odabirom odgovarajuće 

kartice mogu učitavati i svi drugi izvori podataka u QGIS (Slika 2-3). 

 

Slika 2-3. Dijalog prozor Data Source Manager 



Nakon pokretanja funkcije, od korisnika se zahteva da pokaže putanju do rasterske datoteke koju 

želi da učita klikom na dugme  u delu Source. Potrebno je pokazati na datoteku 

T34TDQ_20201026T094111_TCI_10m.jp2 koja se nalazi u folderu Sentinel 2 RGB. Kada je 

format ulazne datoteke poznat, radi lakše pretrage moguće je filtrirati prikaz datoteka na osnovu 

ekstenzije datoteke. Kako je ortofoto u ERDAS JPEG2000 formatu, za ekstenziju datoteke 

odabrati ERDAS JPEG2000 i izvršiti selekciju datoteke (Slika 2-4). 

 

Slika 2-4. Prozor za učitavanje rasterskog sloja 

Nakon odabira fajla kliknuti na dugme Add. Rasterska datoteka će automatski biti učitana u 

radno okruženje QGIS-a u istoj projekciji u kojoj je projekat. Data Source Manager se zatvara 

klikom na dugme Close. JPEG 2000 format je posebno koristan za manipulaciju u QGIS 

okruženju budući da je komprinovan format, zauzima manje memorije od sirovih, 

nekomprinovanih fomata kao što je GeoTIFF i brže se pomera i zumira na ovu podlogu. 

Na isti način izvršiti učitavanje ortofotoa dobijenih fotogrametrijom iz aviona i drona (slike sa 

.tif i .jpg ekstenzijom u folderima 1970, 2001, 2007, 2010, 2018 koji se nalaze u folderu 

Ortofoto). TIF format slike nije kompresovan dok JPG format jeste. Da bi se lakše manipulisalo 

rasterskom datotekom u TIF formatu poželjno je formirati piramide slike. Ovo se postiže desnim 

klikom na sloj Orto1970 i Ortofoto2018 i izborom kartice Pyramids potrebno je štiklirati sve 

raspoložive rezolucije zumiranja sa desne strane i kliknuti na dugme Build Pyramids pa  na Ok. 

Uporediti navedene podloge budući da je to područje aktivnog klizišta, da li je bilo nekih 

značajnijih promena u vidu pomeranja i rušenja zgrada i dr. 



 

Slika 2-5. Prozor za generisanje piramida slika 

Slojevi se pale i gase u prikazu korišćenjem kvadratića koji se štiklira i nalazi se ispred svakog 

lejera učitanog u QGIS. Ukoliko je poželjno da neki sloj bude delimično transparentan, ovo se 

postiže dvoklikom na sloj ili desnim klikom na sloj i odabirom kartice Properties i onda kartice 

transparency gde se korišćenjem klizača u odeljku Global Opacity postiže delimčna providnost 

tog sloja. 

 

Slika 2-6. Podešavanje trasnsparentnosti sloja 



Na kraju je učitane slojeve ortofotoa potrebno grupisati pod nazivom „Ortofoto“, što se postiže 

odabirom više slojeva koje treba grupisati, desnim klikom unutar prozora spiska slojeva i 

izborom opcije Group Selected; odabrani slojevi će automatski biti dodelјeni u novu grupu 

slojeva kojoj se može dodeliti želјeni naziv. 

Sloj se može izvući iz grupe prevlačenjem u deo prozora van grupe ili desnim klikom na sloj u 

grupi i izborom Move Out of the Group. Unutar grupa, dozvolјeno je formiranje podgrupa. 

Klikom na checkbox grupe, prikazaće se ili sakriti svi slojevi dodelјeni grupi. 

Korak 5: Učitavanje poligona granica države i poligona opština 

Za razliku od listova ortofotoa, podaci o opštinama i granicama države za Srbiju nalaze se u 

vektorskoj strukturi podataka i to u vidu geoprostorne vektorske baze podataka GeoPackage. 

Ovo je poseban format geoprostorne baze podataka napravljen za QGIS zajednicu.  

Jedan od načina za učitavanje ovih vektorskih podataka se vrši se pozivanjem iz menija Layer → 

Add Layer → Add Vector Layer. Zatim se u okviru kartice Vector može definisati putanja do 

fajla klikom na dugme  i izborom fajla gadm36_SRB.gpkg u folderu gadm36_SRB_gpkg. 

Podešavanja vektorskog izvora (tip izvora i kodiranje) je potrebno ostaviti na podrazumevanim 

podešavanjima (UTF-8 dozvoljava uvoz alfanumeričkih podataka kao što su slova latinice 

(č,ć,ž,š,đ i dr.) i ćirilice). Klikom na dugme Add prikazuje se dijalog prozor za preuzimanje 

vektorskih slojeva koji se nalaze u Geopackage bazi podataka (Slika 2-7). 



 

Slika 2-7. Preuzimanje vektorskih slojeva iz Geopackage geoprostorne baze podataka 

Kao što se vidi na slici svi slojevi se mogu selektovati odjednom klikom na dugme Select All, a 

štikliranjem opcije Add layers to a group, svi preuzeti vektorski fajlovi biće učitani u okviru 

nove grupe koja će imati naziv kao i Geopackage fajl. 

Drugi način učitavanja ovog tipa fajla jeste klikom na GeoPackage karticu sa leve strane Data 

Source Manager dijalog prozora koji se pokreće iz menija Layer, i kreiranjem 

nove konekcije klikom na dugme New pokazivanjem na gadm36_SRB.gpkg fajl. Nakon toga je 

potrebno kliknuti na dugme Connect kako bi se izlistali vektorski fajlovi u okviru ove baze 

podataka (Slika 2-8). Selektovanjem sloja i kikom na dugme Add, sloj će biti učitan u QGIS. 

Korisna opcija je dugme Set Filter kojim se mogu filtrirati entiteti vektorskog sloja definisanjem 

uslova nad vrednostima atributa. 



 

Slika 2-8. Preuzimanje vektorskih slojeva definisanjem konekcije ka Geopackage bazi podataka 

Nakon definisanja konekcije ka bazi podataka, vektorski slojevi se mogu učitavati korišćenjem 

QGIS Browser-a (Slika 2-9). 

 

Slika 2-9. Preuzimanje vektorskih slojeva iz Geopackage baze podataka putem QGIS Browser-a 

Voditi računa o redosledu iscrtavanja slojeva jer bi prvo trebalo prikazati vektorske podatke (na 

vrhu) a ispod njih rasterske podatke (grupisane karte ortofotoa). Učitani slojevi mogu biti 

uklјučeni/isklјučeni iz prikaza na mapi preko checkbox-a. Sloj može biti selektovan i prevučen 

dole ili gore u legendi, čime se postiže promena redosleda iscrtavanja slojeva. To znači da će 

slojevi koji se nalaze bliže vrhu spiska biti iscrtani preko slojeva pozicioniranih niže u spisku. 

 

Dodatni zadatak: 

Proučite način rada alatki za zumiranje i panovanje koje su smeštene u liniji alatki 

u okviru grupe Map Navigation. 



Korak 6: Otvaranje tabele atributa vektorskog sloja opština 

Otvaranje tabele atributa (opisnih podataka) vektorskih slojeva vrši se desnim klikom na sloj 

gadm36_SRB_1 i odabrati opciju Open Attribute Table koja se pokrećem klikom na alatku  

iz linije alatki. Na ovaj način se otvara tabela atributa ovoj sloja entiteta gde svaki red sadrži 

vrednosti atributa za jedan entitet (geometriju poligona) vektorskog sloja opština (Slika 2-10). 

 

Slika 2-10. Tabela atributa vektorskog sloja opština Srbije 

Kao što se može videti, Kao što se može videti na navedenoj slici, nazivi atributa prikazani su u 

zaglavlju kolona (NAME_0 predstavlja naziv države, NAME_1 naziv opštine i dr.) dok su po 

redovima prikazani uneti slogovi odn. kreirani entiteti u ovom sloju (n-torke u tabeli). 

Pored naziva tabele prikazan je ukupan broj entiteta (engl. Features), broj filtriranih i 

selektovanih entiteta. Nakon filtriranja ili selekcije nekih entiteta, ovaj odnos se menja. Ispod se 

nalazi linija alatki za manipulaciju nad podacima unetim u tabelu. 

Korak 7: Stilizacija vektorskog sloja opština 

Vektorski sloj je potrebno stilizovati tako da budu prikazane samo ivične konture poligona 

crvenom bojom, dok unutrašnjost treba da bude providna. Opcija za stilizaciju se aktivira tako 

što se desnim klikom na ciljni sloj s opštinama pokrene dijalog Layer Properties. Potom se iz 

menija sa strane odabere kartica Symbology i izvrše tražena podešavanja (Slika 2-11). Odabirom 

opcije No Brush za Fill Style unutrašnjost poligona će biti providna, sa Stroke color se definiše 

boja granice poigona a sa Stroke width debljina linije pri čemu se treba voditi računa u kojim se 

jedinicama izražava (sa Meters as Scale i Map Units, debljina linije se neće menjati u zavisnosti 

od nivoa zumiranja dok sa Pixels hoće sa veličinom piksela na monitoru računara). 



 

Slika 2-11. Tabela atributa vektorskog sloja opština Srbije 

Korak 8: Prikaz oznaka opština  

Vektorski sloj opština sadrži atribute za svaki poligon kao što su ID, naziv države, naziv opštine, 

itd. Da bi se u prikaz uključile oznake opština, neophodno je u dijalog prozoru Layer 

Properties odabrati karticu Labels, a potom iz padajućeg menija odabrati Single labels. Label 

with padajući meni definiše željeni atribut koji će biti prikazan za svaki vektorski entitet, u 

konkretnom slučaju atribut „NAME_1“ u kom se nalaze oznake opština. U istom dijalog prozoru 

može se podešavati veličina oznake (Label), font, stil, boja, transparentnost itd. Pogotovo je 

bitno odabrati jedinice za prikaz oznake prilikom definisanja veličine oznake. Ovde je, za razliku 

od jedinica za debljinu linije u prethodnom koraku, poželjnije da jedinice budu map units jer se 

na taj način veličina oznake neće menjati u zavisnosti od nivoa zumiranja u radnom prostoru 

QGIS-a (Slika 2-12). Da bi oznake bile naglašene u odnosu na pozadinu gde je prikazan 

ortofoto, potrebno je uključiti prikaz bafera oko oznaka selekcijom Buffer kartice i štikliranjem 

ove opcije - Draw text buffer (Slika 2-13). 



 

Slika 2-12. Prozor za stilizaciju oznaka sloja opština 

 

Slika 2-13. Prozor za naglašavanje oznaka vektorskog sloja 

 

Dodatni zadatak: 

Proučiti komandu/alatku Identify Features. Kliknuti na neke od poligona 

(opština) u vektorskom sloju (sloj gadm36_SRB_1 da bude označen u spisku 

učitanih slojeva). Sagledati koji se sve atributi vode o parcelama. Pogotovo je 

korisna uključena opcija Auto open form sa kojom se otvara prozor za unos 

opisnih podataka entiteta. 

 



Korak 9: Napredna stilizacija 

Stilizaciju poligona je moguće uraditi na osnovu određenih klasa atributa kao u prethodnim 

vežbama, ali takođe moguće je definisati i gradacijski paletu boja na osnovu količine izražene 

preko nekog atributa (npr. ukupne površine opštinama). Gradacijski prikaz obojenosti poligona 

na osnovu ukupne površine opštine prikazan je u opciji Properties sloja Opštine (Slika 2-15). Na 

isti način se može definisati obojenost za druge atribute. 

Da bi ovo bilo moguće izvesti, prvo je potrebno kreirati novai atribut u kojem će se voditi 

podatak o površini opštine.To je moguće pokretanjem komande Vector → Geometry Tools → 

Add Geometry Attributes. 

 

Slika 2-14. Prozor za dodavanje geometrijskih atributa vektorskom sloju 

Kada je geometrijsko polje kreirano, tada ga je potrebno odabrati kao atribut za koji će biti 

kreirana gradacijska paleta, skalu boja koja će biti korišćena i broj klasa koje će biti kreirane. 

Podešavanje se završava dugmetom Classify, čime se kreirati pravilo za stilizaciju. 



 

Slika 2-15. Prozor za stilizaciju sloja poligona opština 

Korak 10: Učitavanje katastarskih planova i produkata DMT-a 

Katastarski planovi su dobijeni skeniranjem i konvertovani u slike sa ekstenzijom ECW. Učitati 

ih standardno kao i sve druge rasterske datoteke i uporediti sa sadržajem DKP-a. DMT podaci o 

visinama se učitavaju kao klasične rasterske datoteke. 

Korak 11: Vektorski podaci Open Street Maps 

OSM podaci dati su u vidu ESRI Shapefile strukture. Ovi fajlovi se sastoje iz više fajlova istog 

naziva i razičite ekstenzije: 

1. .shp – sastoji se iz podataka o geometriji (koordinata) u vidu tačaka, linija ili poligona 

2. .dbf – tabela baze podataka u kojoj se nalaze vrednosti atributa za svaki od kreiranih 

entiteta 

3. .shx – indeksni fajl za povezivanje entiteta i slogova u tabeli 

4. .prj – parametri projekcije koordinatnog sistema 

  



U ovom formatu dati su sledeći prostorni podaci za područje Srbije: 

1. zgrade - poligoni 

2. tačke od interesa (POI) - tačke 

3. putevi - polilinije 

4. železnice - polilinije 

5. vode - poligoni 

6. vodotoci - polilinije 

Svi vektorski slojevi učitavaju se na isti način preko komande Layer → Add Layer → Add 

Vector Layer. U dijalog prozoru Data Source Manager potrebno je selektovati karticu Vector sa 

leve strane i definisati putanju na .shp fajl za svaki vektorski sloj koji se nalazi po folderima u 

folderu OSM. Za Encoding najbolje je odabrati UTF-8 kako bi u tabeli vrednosti atributa mogle 

imati i latinična slova sa kvačicom ili ćirilicom. Vektorski sloj se dodaje zasebno klikom na 

dugme Add nakon odabira putanje do željenog fajla i odabirom fajla sa ekstenzijom shp. 

 

Slika 2-16. Prozor za učitavanje vektorskog sloja zgrada 

  



Korak 12: Stilizacija vektorskih slojeva 

Potrebno je dodeliti prikladne boje i veličinu simbola navedenim vektorskim slojevima. Voditi 

računa da se za veličinu koriste jedinice Map Units kako se veličina entiteta i oznaka ne bi 

menjala od nivoa zumiranja. Prikazati oznake vodotokova prikladne veličine. 

Entiteti Boja Oznake [Map Units] 

Zgrade Promenjive u zavisnosti od 

namene 

Ne 

Tačke od interesa (POI) Veličine 5 Ne 

Putevi  Ne 

Železnice  Ne 

Vode  Ne 

Vodotoci  Da, veličine 100 

Stilizacija zgrada vrši se u kartici Symbology Properties dijaloga pri čemu se nakon navedenih 

podešavanja mora kliknuti na dugme Classify pa na dugme Ok (Slika 2-17). Za svaki 

pojedinačni tip objekta u legendi se može odabrati odgovarajuća boja. 



 

Slika 2-17. Prozor za podešavanje boja poligona zgrada 

Korak 13: Učitavanje podataka putem WMS-a 

Neke podatke nije potrebno preuzeti na računar već se mogu koristiti kao podloga sa udaljenog 

servera putem WMS/WMTS (Web Map Service) servisa. Ovim se podaci povlače sa udaljenog 

servera u formi rasterskih slika – mapa koje se mogu prikazati u QGIS-u. 

Potrebno je pokrenuti komandu rasterskih Layer → Add Layer → Add WMS/WTMS Layer (Slika 

2-18). Pokrenuti dugme New i uneti naziv nove konekcije kao i URL servisa sa kog se 

preuzimaju podaci: 

http://195.222.98.83/erdas-iws/ogc/wms/Mozaik_ 

Ovde nije potrebno uneti User name i Password radi autentifikacije pristupa ovom serveru.  

 

http://195.222.98.83/erdas-iws/ogc/wms/Mozaik_


 

Slika 2-18. Prozor za kreiranje nove WMS konekcije ka serveru 

Povezivanje putem kreirane konekcije vrši se klikom na dugme Ok. 

Posle se iz QGIS Browsera može prikazati WMS/WMTS konekcija i odabrati deo slika koji 

odgovara traženoj lokaciji (beograd2.ecw). 



 

Slika 2-19. Povezivanje na traženi region putem WMS konekcije 

Korak 14: Učitavanje podataka putem XYZ tiles konekcije 

Sa verzijom 3.xx QGIS-a omogućen je olakšan pristup Google i drugim mapama bez instalacije i 

pokretanja konkretnog plugin-a. U QGIS-u Browser-u potrebno je naći navedenu konekciju i 

desnim klikom pokrenuti komandu New Connection. 

 

Slika 2-20. Povezivanje na GoogleMaps servis putem XYZ konekcije 

Neki od URL-ova potrebnih za pristup različitim sevisima su: 

GoogleMaps: http://mt0.google.com/vt/lyrs=s&hl=en&x={x}&y={y}&z={z} 

http://mt0.google.com/vt/lyrs=s&hl=en&x=%7bx%7d&y=%7by%7d&z=%7bz%7d


GoogleMaps Hybrid sa oznakama: 

http://mt0.google.com/vt/lyrs=y&hl=en&x={x}&y={y}&z={z} 

OpenStreetMap: https://tile.openstreetmap.org/{z}/{x}/{y}.png 

Korak 154: Generisanje slike zgrade supermarketa sa prikazanim slojevima 

Selekciju entiteta sloja je moguće izvršiti na različite načine. Podržani su sledeći tipovi 

selekcija: 

 pojedinačna selekcija; 

 selekcija poligonom; 

 selekcija slobodnom rukom; 

 selekcija kružnicom. 

 

Slika 2-21. Komande za različite tipove selekcija entiteta 

 

Da bi se selektovale sve zgrade tipa supermarket potrebno je prvo otvoriti tabelu atributa desnim 

klikom na sloj zgrada (gis_osm_buildings_a_free_1) i pokretanjem opcije Open Attribute Table. 

Zatim pronaći alatku Select features using an expression  u liniji alatki i u grupi funkcija 

Fields and Values kliknuti na atribut type da bude jednak vrednosti ’supermarket’ (Slika 2-22). 

Dodatni zadatak: 

Proučiti karakteristike različitih tipova selekcija. Isprobati ih na konkretnom 

primeru. 

 

http://mt0.google.com/vt/lyrs=y&hl=en&x=%7bx%7d&y=%7by%7d&z=%7bz%7d
https://tile.openstreetmap.org/%7bz%7d/%7bx%7d/%7by%7d.png


 

Slika 2-22. Komande za različite tipove selekcija entiteta 

Nakon upisane sintakse, potrebno je kliknuti na dugme Select features kako bi se selektovali 

entiteti koji ispunjavaju traženi kriterijum u tabeli i u tom vektorskom sloju. Klikom na dugme 

Close zatvara se navedeni dijalog prozor i zatim se u tabeli atributa mogu videti selektovani 

entiteti ili klikom na dugme Move selection to top  ili prikazom samo selektovanih redova 

klikom na dugme u donjem levom uglu tabele Show Selected Features (Slika 2-23). 



 

Slika 2-23. Prikaz samo selektovanih redova/entiteta u tabeli atributa 

Sortiranje tabele po atributu vrši se klikom na zaglavlje kolone. Potrebno je kliknuti na jedan red 

od četiri selektovana entiteta i kliknuti na alatku Zoom map to the selected row . Na taj način 

će mapa biti zumirana na selektovani entitet (označen žutom bojom - Slika 2-24). 



 

Slika 2-24. Slika selektovane zgrade pri razmeri 1:2000 i uključenim slojevima 

Voditi računa o redosledu (hijerarhiji) iscrtavanja slojeva, kao što je to objašnjeno ranije. Parcele 

sa oznakama treba da se iscrtavaju preko ortofotoa.  

Kreiranje slike se vrši korišćenjem opcije Project → Import/Export → Save Map as PDF, 

čime će trenutni prikaz karte biti sačuvan kao PDF sa slojevima ako se čuva kao  u traženom 

formatu. Ako se štiklira da generiše geoprostorni PDF onda će moći da se gase pojedini QGIS 

slojevi u samom PDF-u. 



 

Slika 2-25. Čuvanje dela kartografskog prika kao geoprostornog PDF-a 

 



 

Kartu je potrebno sačuvati u JPEG formatu pod nazivom „Supermarket_Naziv“. Nakon toga, 

potrebno je ponovo sačuvati QGIS projekat klikom na ikonicu Save  ili komandom Project 

→ Save. 


