
QGIS 

QGIS (ranije Quantum GIS) je GIS aplikacija otvorenog koda koja omogućava 

vizuelizaciju, upravljanje, uređivanje i analizu geoprostornih podataka. Dostupna je na gotovo 

svim platformama. Kao slobodni softver pod GNU-ovom opštom javnom licencom 

(najzastupljenijom licencom za slobodni softver), QGIS se može slobodno modifikovati za 

izvođenje različitih zadataka, a proširenje njegove osnovne funkcionalnosti moguće je i kroz 

korišćenje brojnih dodataka (engl. plugin) razvijenih korišćenjem C++-a ili programskog 

jezika pajtona (engl. python). To čini njegovu najveću prednost. 

Početkom 2002. godine, Gary Sherman otpočinje razvoj Quantum GIS-a kao programa za 

pregled GIS podataka za operativni sistem Linux. Razvoj je nastavljen 2004. godine, kada 

postaje službeni projekat za Open Source Geospatial (OSGeo) fondaciju. Verzija 1.0 je izdata 

u januaru 2009. godine. Napisan C++ programskim jezikom, grafički korisnički interfejs 

QGIS-a koristi kjut (Qt) biblioteke. Kao dodatak Qt-u, softver obuhvata i GeoPackage, GEOS 

i SQLite sistem za upravljanje bazama podataka. Takođe su preporučeni GDAL, GRASS GIS, 

PostGIS i PostgreSQL, s obzirom da pružaju pristup dodatnim formatima podataka. QGIS u 

ovom trenutku obuhvata Desktop i Browser verzije, a razvijena je i eksperimentalna verzija 

softvera za Android operativne sisteme. 

QGIS trenutno održava grupa volontera koji redovno izdaju unapređenja i popravke. Do 2012. 

godine, QGIS je preveden na 48 jezika, a aplikacija je intenzivno korišćena u međunarodnim 

akademskim i profesionalnim krugovima. Trenutno je aktuelna verzija 3.16.0 izdata 23. 

oktobra 2020. godine koja je nazvana Hannover (Slika 1). Verzije koje su imale prefiks 2.xx.xx 

bile su bazirane na programskom jeziku Python 2.7 i njihov grafički korisnički interfejs je 

razvijen korišćenjem Qt4. Sve verzije s oznakama 3.x koriste Python 3 i Qt5. Generalno 

gledano, ne postoje velike razlike između verzija QGIS-a. Stoga se za potrebu izrade vežbi, uz 

određene specifičnosti svake verzije ovog softvera, mogu koristiti kako starije, tako i novije 

verzije. 



 
 

Slika 1. Logo QGIS-a (levo) i uvodni ekran verzije QGIS 3.16 Hannover (desno) 

Svakako najveća prednost jeste što se radi o potpuno besplatnom softveru, odnosno korisniku 

su dostupne sve funkcionalnosti bez ograničenja. S druge strane, mana svih Open Source 

softverskih rešenja je da ne postoji nikakva obaveza proizvođača da pruža podršku u smislu da 

rešava bagove (engl. bugs) koji se mogu javiti prilikom rada. Mada i ovo se prevazilazi na taj 

način što se pojedine firme bave kastomizacijom open source softvera i njegovim održavanjem. 

Na taj način se plaća samo održavanje pomenutog softvera ali ne i kupovina istog kao kod 

komercijalnih rešenja. 

Instalacija QGIS-a 

QGIS instalaciju potrebno je preuzeti sa zvaničnog web sajta QGIS projekta: 

https://qgis.org/en/site/. Kliknuti na dugme Download Now kojim će se proslediti na stranicu 

sa preuzimanjima instalacija softvera. Radi direktne instalacije QGIS Desktop aplikacije 

potrebno je kliknuti na link QGIS Standalone Installer Version 3.16 pri čemu treba voditi 

računa o tome da li je računar 32-bitna ili 64-bitna mašina (Slika 2). Instalacioni fajl QGIS-a 

zauzima oko 405MB (.exe ekstenzija). Pokrenuti navedenu izvršnu datoteku i instalirati 

program. 

 

Slika 2. Preuzimanje QGIS Desktop instalacije sa zvaničnog web sajta 

Korisnički interfejs QGIS-a 

Među najvećim prednostima QGIS-a jesu njegova intuitivnosti i preglednost, čime je 

omogućeno jednostavno snalaženje u softveru. Komande su raspoređene po menijima, a mogu 

se postaviti i prečice u paletama sa alatkama (ili linijama alatki, engl. toolbars). Po 

podrazumevanim podešavanjima, interfejs softvera sačinjavaju (Slika 3): 

https://qgis.org/en/site/


1. linija menija; 

2. horizontalna linija alatki; 

3. odeljak za pretragu fajlova (Browser);  

4. bočna (vertikalna) linija alatki; 

5. prozor sa spiskom učitanih slojeva (Layers); 

6. prikaz karte; 

7. statusna linija.  

Ukoliko se neki odeljak ili linija ne prikazuje prilikom pokretanja QGIS-a, iste je moguće 

prikazati pokretanjem komandi iz menija View → Panels i View → Toolbars. 

 

Slika 3. Korisnički interfejs QGIS-a sa obeleženim elementima 

Pored pobrojanih komponenti interfejsa, korisniku je u okviru kartice View → Panels… iz 

linije menija ili desnim klikom na neki toolbar, na raspolaganju dodatno prilagođavanje radnog 

okruženja ubacivanjem i izbacivanjem različitih kartica, prozora, itd. Odabrane komponente je 

dodatno moguće pokazivačem miša reorganizovati i grupisati, u skladu sa potrebama i željama 

korisnika. 
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Linija menija  

Linija menija omogućava pristup raznim QGIS funkcionalnostima korišćenjem standardnog 

hijerarhijskog menija. Meniji na najvišem nivou sumiraju opcije menija izlistanih ispod. Neke 

alatke u okviru menija pored naziva imaju i odgovarajuću ikonicu koja odgovara ikonici te 

funkcije u liniji alatki i skup tastera na tastaturi koji predstavljaju prečicu za njeno pokretanje. 

Prečice kojima se pristupa pomoću tastature mogu biti podešene iz menija Settings → 

Keyboard Shortcuts... Izgled linije menija zavisi i od raspoloživih dodataka, zato što će neke 

opcije menija biti prikazane samo pod uslovom da je odgovarajući plugin učitan. 

Horizontalna i bočna linija alatki  

Najčešće korišćene funkcionalnosti mogu biti prikazane u nekoj od liniji alatki radi olakšanog 

pristupa. Linija alatki je organizovana po grupama alatki i omogućava pristup istim funkcijama 

kao i meniji, s tim da ima i dodatne alatke za interakciju sa kartom (prevlačenje, uvećanje itd).  

Zadržavanjem pokazivača na ikonici alatke prikazuje se kratak opis funkcionalnosti koje 

ona nudi. U okviru menija View → Toolbars omogućeno je prilagođavanje i odabir alatki koje 

će biti prikazivane u okviru linije alatki. Svaka grupa alatki zatim može biti pozicionirana bilo 

gde unutar interfejsa, po želji korisnika. Alatkama koje nisu prikazane u okviru linije alatki 

pristupa se iz odgovarajućeg menija iz linije menija. 

Odeljak za pretragu fajlova 

Prikazuje hijerarhijsku strukturu diskova, direktorijuma i datoteka računara, radi jednostavnog 

kretanja, manipulacije i učitavanja u program. Prevlačenjem datoteka sa geoprostornim 

podacima u područje karte, automatski se učitavaju podaci u tekući projekat. Ovo je isto 

moguće izvršiti prevlačenjem odgovarajućeg fajla iz Windows Explorer-a u radno okruženje 

QGIS-a. Takođe, odeljak prikazuje i prečice za povezivanje sa odgovarajućom bazom podataka 

(na primer, GeoPackage, PostGIS, Oracle, SpatiaLite, MSSQL Spatial i druge) i kreiranje 

WMS/WFS, GeoNode i drugih konekcija. 

Prozor sa spiskom učitanih slojeva 

U okviru ove kartice se prikazuju svi slojevi (engl. Layers) koji su učitani u tekući projekat. 

Učitani slojevi mogu biti uključeni/isključeni iz prikaza na mapi preko checkbox-a. Sloj može 

biti selektovan i prevučen dole ili gore u legendi, čime se postiže promena redosleda iscrtavanja 

slojeva. To znači da će slojevi koji se nalaze bliže vrhu spiska biti iscrtani preko slojeva 

pozicioniranih niže u spisku. 

Obezbeđeno je grupisanje slojeva, što se postiže na dva načina: 

 desnim klikom u unutrašnjosti prozora spiska slojeva i odabirom opcije  

Add Group iz padajućeg menija; zatim je potrebno dodeliti naziv grupi i tasterom 

Enter potvrditi kreiranje nove grupe; u kreiranu grupu na kraju treba premestiti željene 

slojeve; 



 odabirom više slojeva, desnim klikom na spisak selektovanih slojeva i izborom opcije 

Group Selected; odabrani slojevi će automatski biti dodeljeni u novu grupu slojeva 

kojoj se može dodeliti željeni naziv. 

Sloj se može izvući iz grupe prevlačenjem u deo prozora van grupe ili desnim klikom na sloj i 

izborom komande Move to Top. Unutar grupa, dozvoljeno je formiranje podgrupa. Klikom na 

checkbox grupe prikazaće se ili sakriti svi slojevi dodeljeni grupi. 

Prikaz karte 

Predstavlja glavni deo interfejsa u kojem se vrši vizuelizacija trenutno uključenih slojeva. 

Sadržaj karte prikazane u ovom prozoru zavisi od vektorskih i rasterskih slojeva koji su 

izabrani za prikaz u spisku učitanih slojeva karte, stilizacije slojeva i njihovog redosleda 

iscrtavanje.  

Promena uvećanja prikaza je omogućena rotiranjem točkića na mišu ili . Pomeranje prikaza 

karte se može izvesti na više načina: koristeći strelice za navigaciju na tastaturi, držanjem 

tastera space i pomeranjem miša ili klikom točkića i pomeranjem miša. Takođe je moguće 

koristiti i grupu alatki za navigaciju iz linije sa alatkama kako bi se vršila interakcija s kartom 

u ovom prozoru. 

Statusna linija 

Statusna linija prikazuje sledeće informacije: 

8. trenutna pozicija kursora u koordinatnom sistemu karte (npr. u metrima ili 

decimalnim stepenima); 

9. taster koji omogućava promenu između prikaza koordinata kursora i koordinata 

obuhvata karte, što se menja sa nivoom zumiranja; 

10. razmera u kojoj je trenutno prikazana karta; na raspolaganju je i selektor razmere 

koji nudi izbor predefinisanih nivoa razmere od 1: 500 do 1: 1 000 000; 

11. taster koji omogućava zaključavanje prikaza karte u odabranoj razmeri; umesto 

promene razmere, kada je ova opcija uključena menjaće se samo stepen uvećanja 

sadržaja; 

12. stepen uvećanja sadržaja za trenutno odabranu razmeru; 

13. ugao rotacije prikaza karte; 

14. checkbox kojim se definiše da li će sadržaj prikaza karte biti iscrtavan u realnom 

vremenu; 

15. EPSG kôd projekcije u kojoj se prikazuje sadržaj karte; klikom na ikonicu otvara se 

prozor Project Properties za trenutni projekat. 

 

Slika 4. Statusna linija sa komponentama 



1.1.1 Rukovanje vektorskim podacima u QGIS-u 

Funkcionalnosti za manipulaciju podacima u vektorskom formatu u QGIS-u smeštene su u 

okviru menija Vector. U okviru tog menija, na jednom mestu, na raspolaganju je veliki broj 

mogućnosti za rešavanje vektorski baziranih GIS zadataka. U zavisnosti od toga da li je neki 

dodatak instaliran, Vector meni može sadržati različite funkcionalnosti. Podrazumevane 

funkcionalnosti u okviru ovog menija obuhvataju: 

 Alatke za geoprocesiranje (Geoprocessing tools); 

 Geometrijske alatke (Geometry tools); 

 Alatke za analizu (Analysis tools); 

 Alatke za manipulaciju podacima (Data management tools). 

 Alatke za istraživanje (Research tools); 

U nastavku će biti prikazane funkcionalnosti svake od ovih grupa. 

Alatke za geoprocesiranje (Geoprocessing Tools) 

Tabela 1. Spisak i opis funkcionalnosti alatki za geoprocesiranje 

Alatka Ikonica Opis (funkcionalnost) 

Bafer fiksnog 

rastojanja  

(Buffer) 
 

Kreiranje bafera fiksne veličine oko entiteta ulaznog 

sloja. Veličina bafera može biti definisana i na 

osnovu atributa rastojanja sloja. 

Odsecanje  

(Clip)  
Vrši izdvajanje područja ulaznog sloja koje se 

poklapa sa područjem sloja za odsecanje. 

Konveksna ljuska  

(Convex Hull)  
Kreiranje minimalne konveksne ljuske ulaznog sloja 

ili entiteta sloja na osnovu jedinstvenog ID polja. 

Razlika  

(Difference)  
Vrši izdvajanje područja ulaznog sloja koje se ne 

poklapa sa područjem sloja za isecanje. 

Stapanje  

(Dissolve)  

Vrši spajanje entiteta na osnovu definisanog polja 

atributa. Svi entiteti sa istom vrednošću atributa biće 

spojeni u jedinstveni entitet. 

Presek  

(Intersection)  
Vrši presek slojeva tako da rezultujući sloj sadrži 

područje gde se oba ulazna sloja poklapaju. 

Simetrična razlika  

(Symmetrical 

Difference) 
 

Vrši preklapanje ulaznih slojeva tako da rezultujući 

sloj sadrži područja oba ulazna sloja bez područja 

preklapanja. 

Unija  

(Union)  

Vrši preklapanje ulaznih slojeva tako da rezultujući 

sloj sadrži i preklapajuća i nepreklapajuća područja 

ulaznih slojeva. 



Uklanjanje 

selektovanih poligona  

(Eliminate Selected 

polygons) 

 

Vrši kombinovanje selektovanih poligona ulaznog 

sloja sa određenim susednim poligonima tako što 

briše zajedničku granicu. Uklanjaju se mali poligoni. 

Geometrijske alatke (Geometry tools) 

Tabela 2. Spisak i opis funkcionalnosti geometrijskih alatki 

Alatka Ikonica Opis (funkcionalnost) 

Centroidi 

(Centroids)  
Računanje centroida svakom entitetu ulaznog 

površinskog sloja. Preuzima njegove atribute. 

Sakupljanje geometrija 

(Collect Geometries)  

Spajanje više entiteta u jedinstveni entitet na osnovu 

jedinstvenog ID polja atributa, više vrednosti 

atributa ili svih geometrija spajanjem u jednu.  

Izdvajanje temena  

(Extract Vertices)  
Izdvajanje prelomnih tačaka/temena iz linijskog ili 

površinskog sloja i izvoz kao novog tačkastog sloja. 

Složeni entiteti u 

jednostavne  

(Multipart to 

Singleparts) 

 

Konverzija složenih entiteta (koji se sastoje od više 

pojava) u pojedinačne entitete. Rezultujući entiteti 

su prosti površinski entiteta i linije. 

Pojednostavljivanje  

(Simplify)  

Generalizacija ulaznih linijskih ili površinskih 

entiteta koristeći izmenjeni Daglas-Pojkerov (engl. 

Douglas-Peucker) algoritam. 

Provera validnosti 

geometrije  

(Check Validity) 
 

Utvrđivanje da li se poligoni međusobno preklapaju, 

da li imaju zatvorene rupe i da li je ispoštovan 

utvrđen redosled čvorova. Na raspolaganju su dve 

metode za utvrđivanje validnosti: QGIS i GEOS 

koje imaju značajno različito ponašanje. Ovu alatku 

ne treba mešati sa dodatkom za proveru topologije 

(Topology Checker). 

Delanijeva triangulacija  

(Delaunay 

Triangulation) 
 

Određivanje i izvoz Delanijeve triangulacije kao 

površinskog sloja na osnovu specificiranog ulaznog 

tačkastog sloja. 

Progušćavanje 

prebrojavanjem 

(Densify by Count) 
 

Progušćavanje ulaznih linijskih ili površinskih 

entiteta dodavanjem temena. 

Dodavanje 

geometrijskih atributa  

(Add Geometry 

Attributes) 

 

Dodavanje geometrijskih informacija vektorskom 

sloju: 

 tačkasti sloj – X i Y koordinate; 

 linijski sloj – Dužina; 

 površinski sloj – Površina i obim. 



Linije u površine  

(Lines to polygons)  Konverzija linijskih entiteta u površinske entitete. 

Površine u linije  

(Polygons to lines)  Konverzija površinskih entiteta u linijske entitete. 

Voronoi poligoni  

(Voronoi Polygons)  

Određivanje i izvoz Voronoi poligona kao 

površinskog sloja na osnovu specificiranog ulaznog 

tačkastog sloja. 

Alatke za analizu (Analysis tools) 

Tabela 3. Spisak i opis funkcionalnosti alatki za analizu 

Alatka Ikonica Opis (funkcionalnost) 

Presek linija  

(Line Intersections)  

Određivanje preseka linijskih entiteta i izvoz 

rezultata kao tačkaste SHP datoteke. Ignorišu se 

preseci linija koje imaju zajedničke segmente. 

Srednja vrednost 

koordinata 

(Mean Coordinate(s)) 
 

Računanje prostog ili ponderisanog težišta celog 

vektorskog sloja ili pojedinačnih entiteta sloja 

(moraju imati jedinstven ID atribut). 

Osnovna statistika za 

polje 

(Basic Statistics for 

Fields) 
 

Računanje osnovne statistike (srednja vrednost, 

standardna devijacija, broj elemenata, koeficijent 

varijacije) za ulazno polje atributa. 

Broj tačaka u poligonu 

(Count Points in 

Polygon) 
 

Određivanje broja tačaka koje se nalaze unutar 

svakog poligona specificiranog površinskog sloja. 

Matrica rastojanja 

(Distance Matrix)  

Određivanje rastojanja između dva tačkasta sloja i 

predstavljanje rezultata kao: 

 kvadratne matrice rastojanja; 

 linearne matrice rastojanja; 

 sumarnog pregleda sračunatih rastojanja. 

Podržano je i ograničavanje rastojanja na  

k-najbližih suseda. 

Lista jedinstvenih 

vrednosti 

(List Unique Values) 
 

Izlistavanje spiska svih jedinstvenih vrednosti za 

odabrani atribut ulaznog vektorskog sloja. 

Analiza najbližeg 

susedstva  

(Nearest Neighbor 

Analysis) 
 

Računanje statistike najbližeg susedstva radi 

procene stepena klasterisanja ulaznog tačkastog 

sloja. 



Suma dužina linija 

(Sum Line Lengths)  

Određivanje ukupne dužine linija koje presecaju 

poligon i njihovog ukupnog broja u svakom 

poligonu. 

Alatke za manipulaciju podacima (Data management tools) 

Tabela 4. Spisak i opis funkcionalnosti alatki za manipulaciju podacima 

Alatka Ikonica Opis (funkcionalnost) 

Spajanje vektorskih 

slojeva 

(Merge Vector Layers) 
 

Spajanje više SHP datoteka unutar direktorijuma u 

jednu uzimajući u obzir tip sloja (tačkasti, linijski, 

površinski). 

Reprojekcija sloja  

(Reproject Layer)  
Specificiranje koordinatnog sistema za SHP 

datoteke čiji koordinatni sistem nije definisan. 

Kreiranje datoteke 

prostornog indeksiranja  

(Create Spatial Index) 
 

Kreiranje datoteke prostornog indeksiranja za OGR 

- podržane formate. 

Spajanje atributa na 

osnovu lokacije  

(Join Attributes by 

Location) 

 

Spajanje atributa vektorskih slojeva na osnovu 

prostornih odnosa. Atributi jednog vektorskog sloja 

su pridruženi atributima drugog sloja i sačuvani kao 

nova datoteka. 

Razdvajanje vektorskog 

sloja  

(Split Vector Layer) 
 

Razdvajanje ulaznog sloja na više nezavisnih 

slojeva na osnovu definisanog polja atributa. 

Alatke za istraživanje (Research tools) 

Tabela 5. Spisak i opis funkcionalnosti alatki za istraživanje 

Alatka Ikonica Opis (funkcionalnost) 

Selekcija na osnovu 

lokacije  

(Select by location) 
 

Selekcija entiteta koristeći njihovu relativnu 

lokaciju u odnosu na drugi sloj radi kreiranja nove 

selekcije ili dodavanja/oduzimanja iz postojeće 

selekcije entiteta. 

Kreiranje grida  

(Create Grid)  
Kreiranje tačkastog, linijskog ili površinskog grida 

u skladu sa korisnički definisanim rastojanjem. 

Ekstrakcija obuhvata sloja  

(Extract Layer Extent)  
Generiše novi vektorski sloj sa sadržajem 

obuhvaćenim MBB ulaznog sloja. 

Slučajne tačke unutar 

obuhvata karte  

(Random Points in 

Extent) 

 
Kreiranje pseudoslučajnih tačaka unutar obuhvata 

karte (fiksan ili promenljiv broj tačaka). 



Slučajne tačke unutar 

granica sloja  

(Random Points in Layer 

Bounds) 

 
Kreiranje pseudoslučajnih tačaka unutar obuhvata 

sloja (fiksan ili promenljiv broj tačaka). 

Slučajne tačke unutar 

poligona (Random Points 

Inside Polygons) 
 

Kreiranje pseudoslučajnih tačaka unutar površine 

ulaznog površinskog sloja (fiksan ili promenljiv 

broj tačaka). 

Slučajna selekcija 

(Random Selection)  
Slučajna selekcija n entiteta ili n procenata entiteta. 

Slučajna selekcija iz 

podskupa  

(Random Selection 

Within Subsets) 

 
Slučajna selekcija entiteta iz podskupa definisanog 

jedinstvenim ID atributom. 

Grid tačaka  

(Regular points)  
Kreiranje pravilnog grida tačaka za definisano 

područje i izvoz kao tačkaste SHP datoteke. 

1.1.2 Rukovanje rasterskim podacima u QGIS-u 

Kako se rad sa rasterskim podacima u QGIS-u bazira na GDAL biblioteci, svi formati rasterskih 

podataka implementirani u GDAL biblioteci se mogu koristiti. U ovoj biblioteci je podržano 

više od 100 formata rasterskih podataka. Za učitavanje rasterskih podataka u radni prostor 

QGIS-a koristi se komanda Layer → Add Layer → Add Raster Layer (dugme ). 

Postoji mogućnost učitavanja više od jedne rasterske datoteke istovremeno, tako što se 

zadrži neki od tastera Ctrl ili Shift i odabere više datoteka u Open a GDAL Supported Raster 

Data Source dijalog prozoru. Nakon učitavanja podataka, potrebno je podesiti koordinatni 

sistem, a to se radi tako što se iz popup menija (dobija se klikom na desni taster miša kada je 

kursor iznad imena sloja) aktivira opcija Set CRS → Set Layer CRS. Ovaj meni će najčešće biti 

automatski pokrenut prilikom učitavanja podataka u QGIS. 

Desnim klikom miša na naziv sloja i odabirom opcije Properties otvara se dijalog prozor 

Layer Properties. U ovom prozoru se nalaze osnovne informacije o rasteru, kao i opcije kojima 

se podešavaju načini vizuelizacije rasterskih podataka. 

Veliku pogodnost u korišćenju QGIS-a za rad s rasterskim podacima obezbeđuju dodaci 

(engl. plugins) specijalizovani za izvršavanje određenih funkcija. Neke od mogućnosti za 

obradu rasterskih podataka koji su sastavni deo standardne instalacije 

QGIS-a su: 

 Raster Calculator; 

 Align Rasters; 

 Georeferencer; 



 Heatmaps; 

 Terrain Analysis; 

 Zonal Statistics; 

 različite GDAL komande. 

Raster Calculator 

QGIS ima ugrađene osnovne funkcije za obradu rasterskih podataka koje su dostupne preko 

opcije Raster Calculator. Pomoću ove komande mogu se vršiti razne operacije nad vektorskim 

podacima korišćenjem operatora dostupnih u modulu. Ova funkcija se pokreće komandom 

Raster → Raster Calculator. 

Dijalog prozor Raster Calculator-a se sastoji iz nekoliko delova (Slika 5): 

 Raster Bands; 

 Result Layer; 

 Operators; 

 Raster Calculator Expressions. 

 

Slika 5. Izgled Raster Calculator dijalog prozora 

U delu Raster Bands prikazani su svi rasteri učitani u QGIS projekat i oni su dostupni za obradu. 

Da bi raster bio dodat u polje Raster Calculator Expressions, potreban je samo dvostruki klik 

na naziv željenog rastera. 



U delu Result Layer definiše se naziv sloja i lokacija izlazne datoteke na disku. Postoji 

mogućnost odsecanja dela ulaznog rastera preko X, Y koordinata granica ili unošenjem broja 

vrsta i kolona, čime se definiše rezolucija izlaznog rastera. Ukoliko ulazni i izlazni raster imaju 

različitu rezoluciju, za resampling se koristi interpolacija ,,najbliži sused“. Za izlazni raster se 

definiše i format podataka. Čekiranjem polja Add result to project, izlazni sloj će biti dodat u 

QGIS projekat. 

Deo Operators sadrži sve raspoložive operatore. Za dodavanje nekog operatora potreban je 

samo klik na željeni operator. Na raspolaganju su matematički operatori, trigonometrijske 

funkcije, zagrade, znakovi jednakosti i nejednakosti itd. 

Funkcija kojom se dobija izlazni raster je ispisana u delu Raster Calculator Expressions. 

Ona predstavlja kombinaciju ulaznih rastera, operatora i brojeva. 

Align Rasters 

Alatka Align Rasters za ulazne podatke uzima nekoliko rastera koje onda treba da savršeno 

uskladi, u smislu: 

 reprojekcije u isti koordinatni sistem; 

 uzorkovanja na istu veličinu piksela; 

 odsecanja područja od interesa; 

 promene razmere kada je potrebno. 

Svi rasteri će se sačuvati u drugim datotekama. Funkcija se pokreće komandom Raster → Align 

Rasters. Klikom na dugme  otvara se prozor za odabir rasterskog sloja. U istom prozoru se 

unosi putanja na kojoj će se snimiti izlazni raster. kao i metoda resamplinga. Na raspolaganju 

se nalaze metode: 

 najbliži sused – Nearest Neighbor; 

 bilinearna – Bilinear (2×2 kernel); 

 kubna konvolucija – Cubic (4×4 kernel); 

 kubni B-splajn – Cubic B-Spline (4×4 kernel); 

 Lancoš interpolacija – Lanczos (6×6 kernel); 

 srednja vrednost svih piksela s vrednostima – Average; 

 moda (najčešća vrednost) – Mode; 

 maksimum – Maximum; 

 minimum – Minimum; 

 medijana – Mediane; 

 prvi kvartil – First Quartile (Q1); 

 treći kvartil – Third Quartile (Q3). 

Nad odabranim rasterskim slojem se mogu primeniti sledeće opcije: 



 odabir referentnog sloja; 

 prebacivanje u novi koordinatni sistem; 

 postavljanje različite veličine piksela; 

 postavljanje različitog pomeraja grida; 

 odsecanje područja od interesa; 

 definisanje veličine izlaznog rastera; 

 dodavanje izlaznog rastera u prikaz. 

Georeferencer 

Dodatak Georeferencer služi za georeferenciranje rasterskih podataka. Georeferenciranje 

predstavlja postupak dodeljivanja realnih koordinata svakom pikselu rastera. Koordinate 

kontrolnih tačaka se najčešće dobijaju terestričkim merenjima (npr. GNSS metodom). Kao 

kontrolne tačke mogu se koristiti i temena decimetarske ili poludecimetarske mreže na 

skeniranim planovima. Ovaj modul se pokreće klikom na Raster → Georeferencer pri čemu 

ovaj plugi mora biti instaliran uključen u spisku Plugins → Manage and Install Plugins. 

Postupak georeferenciranja u QGIS-u je sledeći: 

 učitati raster komandom File → Open raster ili klikom na dugme  ; 

 odabrati kontrolne tačke na rasteru i dodeliti im koordinate ciljnog koordinatnog 

sistema; 

 definisati parametre transformacije; 

 pokrenuti proces georeferenciranja. 

Odabir kontrolnih tačaka na rasteru vrši se pomoću komande Edit → Add point (dugme ). 

Kontrolna tačka se može izbrisati komandom Edit → Delete point (dugme ) ili se njena 

pozicija može izmeniti komandom Edit → Move GCP point (dugme ). Prilikom odabira 

kontrolne tačke na rasteru, pojavi se prozor za upis koordinata ciljnog koordinatnog sistema. 

Moguće je izvršiti izvoz kontrolnih tačaka opcijom File → Save GCP points as... (dugme 

) ili njihovo učitavanje opcijom File → Load GCP points (dugme ). 

Nakon odabira kontrolnih tačaka, potrebno je definisati parametre transformacije. 

Komandom Settings → Transformation settings (dugme ) otvara se dijalog prozor za 

podešavanje parametra transformacije. U okviru ovog prozora, vrši se odabir tipa 

transformacije, resamplinga, kompresije, lokacije izlaznog rastera na disku i ciljnog 

koordinatnog sistema. Moguće je generisati PDF kartu i PDF izveštaj. 

Raspoloživi tipovi transformacije su: 



 linearna – Linear; 

 Helmertova – Helmert; 

 polinomska 1 – Polynomial 1; 

 polinomska 2 – Polynomial 2; 

 polinomska 3 – Polynomial 3; 

 splajn tankim pločama – Thin Plate Spline; 

 projektivna – Projective. 

Moguće je izabrati jedan od pet različitih metoda resampliga: 

 najbliži sused – Nearest Neighbor; 

 linearna – Linear; 

 kubna – Cubic; 

 kubni splajn – Cubic Spline; 

 Lancoš interpolacija – Lanczos. 

Opcijom Settings → Configure Georeferencer otvara se prozor za podešavanje parametara 

samog Georeferencer-a (način prikazivanja tačaka, korišćene jedinice, margine PDF izveštaja, 

veličina papira za PDF kartu). 

Kada su kontrolne tačke odabrane i svi ostali parametri podešeni, proces georeferenciranja se 

pokreće komandom File → Start georeferencing (dugme ). 

Heatmaps 

Opcija Heatmaps je jedan od najboljih dodataka za generisanje rasterske datoteke na osnovu 

ulaznih tačaka, a kada boja (intenzitet) određenog piksela izlaznog rastera treba da se dobije 

klaster analizom. Heatmaps se koristi za lako pronalaženje (identifikovanje, uočavanje) mesta 

s velikom koncentracijom podataka (aktivnosti, vrednosti, dešavanja). Takođe je korisna za 

klasifikovanje i hotspot analize. 

Na osnovu ulaznih podataka u obliku rasutih tačaka, kao izlaz dobija se raster u željenom 

formatu, tako da svaki piksel svojom vrednošću reprezentuje koncentraciju tačaka u susedstvu. 

Susedstvo se definiše poluprečnikom (map units ili meters). Postoji mogućnost definisanja 

veličine rastera brojem vrsta i redova ili definisanjem veličine piksela po X, Y koordinatnim 

osama. Ukoliko se definiše veličina izlaznog rastera, odnosno menja veličina rastera, dolazi do 

potrebe za resamplingom, pa je potrebno definisati i oblik kernela. Kernel se koristi za 

računanje vrednosti piksela izlaznog rastera zbog razlike veličina piksela ulaznog i izlaznog 

rastera. Raspoloživi kerneli su: Quartic, Triangular, Uniform, Triweight i Epanechinikov. 

Postoji mogućnost definisanja poluprečnika i težine na osnovu atributa (kolone). 



Terrain Analysis 

Dodatak Terrain Analysis služi za računanje nagiba, aspekta, karte senčenog modela, indeksa 

hrapavosti i karte reljefa na osnovu digitalnog modela visina (DEM). Veoma je intuitivan i 

jednostavan za upotrebu. Funkcije ovog modula se nalaze u podmeniju Analysis menija Raster 

(Aspect, Hillshade, Roughness, Slope i drugi). 

Na osnovu histograma rastera koji predstavlja nagib terena (engl. Slope), može se doći do 

informacije o konfiguraciji terena, odnosno da li je teren ravan ili brdovit. Tamni pikseli 

predstavljaju ravan teren, dok svetli pikseli predstavljaju strme padine planina. 

Analiziranjem vrednosti piksela rastera koji se odnosi na pravac pružanja nagiba terena 

(engl. Aspect), određuju se minimalna i maksimalna vrednost koje se kreću u rasponu od 0 do 

360 stepeni, polazeći od pravca severa i idući u kontrasmeru i odnosu na kretanje kazaljke na 

satu. Korišćenjem ovog rastera, za svako brdo se može odrediti pravac pružanja nagiba (pada) 

terena. Moguće je identifikovati sever 0° ili 360°, jug 180°, istok 270°, zapad 90°. Vrednosti 

između ovih opsega predstavljaju mešavinu susednih pravaca. Na primer, 225° predstavlja 

padinu brda sa jugoistočnim smerom pružanja pada. 

Funkcijom Hillshade se kreira senčeni model koristeći poziciju osvetljenja i senku, kako bi 

se proizveo trodimenzionalni utisak na karti.  

Vrednost indeksa hrapavosti (engl. Ruggedness index) se računa za svaki piksel posebno, 

sumiranjem promene vrednosti visine u okviru pikselskog grida veličine 3×3. Hrapavost se 

koristi kao mera heterogenosti terena u pogledu visine. Vrednost indeksa hrapavosti se 

klasifikuje po kategorijama radi predstavljanja različitih tipova terena. Postoje sledeće 

kategorije terena (Tabela 6): 

Tabela 6. Kategorije terena u zavisnosti od indeksa hrapavosti 

Ravan teren 0 – 80 m 

Skoro ravan 81 – 116 m 

Blago hrapav 117 – 161 m 

Umereno hrapav 162 – 239 m 

Srednje hrapav 240 – 497 m 

Visoko hrapav 498 – 958 m 

Ekstremno hrapav 959 – 4394 m 

Na osnovu maksimalne vrednosti indeksa hrapavosti dobija se informacija o tipu terena na tom 

rasteru. Histogram daje informaciju o terenu poređenjem vrednosti histograma s vrednostima 

iz tabele. 

Komandom Relief se kreira prikaz reljefa u RGB formatu, tj. dobija se obojeni senčeni model 

terena na osnovu digitalnog modela visina. Važan deo predstavlja izbor boja za visine. QGIS 

ima mogućnost da analizira frekvenciju distribucije visina u digitalnom modelu visina i na 

osnovu toga predloži klasifikaciju piksela po bojama, u zavisnosti od promena na histogramu. 

Moguće je promeniti šemu boja, odnosno korisnik je može sam definisati. Može se i generisati 

karta senčenog modela u rasponu sivih tonova. 



Karta reljefa je kombinacija tri komponente, sa ciljem da se stekne trodimenzionalni utisak: 

 senčeni model terena s pozicijom osvetljenja severozapadno (300°) i obojen u 

zavisnosti od visine (vrednosti piksela); 

 senčeni model terena sa sivim tonovima u zavisnosti od vrednosti nagiba; ugao 

osvetljenja senčenog modela terena se razlikuje od prvog za 15% tako da ima bolji 

kontrast; ova komponenta prilikom kreiranja finalne karte ima 30% težine; 

 senčeni model terena s pozicijom osvetljenja na zapadu (270°) i žutom bojom piksela 

koji su direktno okrenuti izvoru osvetljenja; u kreiranju finalne karte reljefa učestvuje 

sa 10% težine. 

Zonal Statistics 

Funkcija Zonal Statistics se koristi za dobijanje statističkih parametara u okviru svake zone. Za 

izvođenje analiza, najpre je potreban raster s podacima na osnovu kojih se izvode statističke 

analize. Dalje, potrebna je vektorska datoteka s poligonima koji definišu zone u okviru kojih 

se analiziraju podaci. Kao izlaz, dobija se vektorska datoteka koji sadrži dodate kolone: 

 count – broj piksela u zoni; 

 mean – srednja vrednost piksela u zoni; 

 sum – zbir svih vrednosti piksela u zoni. 

Različite GDAL komande 

GDAL Tools obezbeđuje funkcije za dodeljivanje projekcije rasteru, promenu projekcije, izvoz 

projekcije rastera, razne analize rastera, odsecanje područja od interesa, konstruisanje izohipsi, 

mozaikovanje. 

 Assign Projection služi za dodeljivanje projekcije rasterskim podacima. 

 Warp (Reproject) služi za promenu projekcije rasterskim podacima. 

 Rasterize služi za kreiranje rasterskih podataka na osnovu vektorskih podataka. 

 Polygonize služi za kreiranje vektorskih podataka na osnovu rasterskih podataka. 

 Clip Raster služi za odsecanje područja od interesa na rasteru.  

Postoje dva načina izbora područja od interesa za odsecanje: 

 Extent – selektovanjem područja od interesa pomoću kursora miša; koordinate 

krajnjih tačaka budu automatski selektovane; 

 Mask layer – korišćenjem nekog drugog sloja koji ima ulogu maske područja. 

Contour je opcija koja služi za kreiranje izohipsi na osnovu rastera. 

DEM (Terrain models) je funkcija slična dodatku Terrain Analysis. Moguće je izračunati: 

Hillshade, Slope, Aspect, Color relief, TRI (Terrain Ruggedness Index), TPI (Topographic 

Position Index), Roughness na osnovu digitalnog modela visina. 



Merge služi za mozaikovanje više rasterskih podataka koji se preklapaju, čime se kreira 

jedinstvena rasterska datoteka. 

Build Virtual Raster generiše virtuelni raster koji koristi pojedine kanale više učitanih 

rastera i ne stvara novi raster koji fizički čuva na disku već ga privremeno generiše u memoriji 

računara. 

Build Overviews (Pyramids) generiše piramide slika za određeni nivo zumiranja rastera i 

stoga olakšava lakšu manipulaciju rasterskim datotekama u prikazu karte. 

Ukoliko neka od navedenih funkcija nije vidljiva u liniji menija, ista se može pretražiti i 

naći u okviru palete alatki Processing Toolbox koji se pokreće preko Processing → Toolbox. 

Više o softverskom paketu QGIS, njegovim funkcijama za rad sa prostornim podacima, 

konfiguraciji softvera, korisničkom interfejsu, integraciji sa drugim softverskim aplikacijama i 

bibliotekama (recimo, GRASS GIS) i slično, pročitati u publikaciji QGIS User Guide (QGIS 

Development Team 2017). 

Čitav niz problema i zadataka koji se odnose na rad sa vektorskim podacima, kao i način 

njihovog rešavanja u softverskom okruženju QGIS-a detaljno je opisan u poglavljima:  

 3. Module: Creating a Basic Map, 

 4. Module: Classifying Vector Data, 

 6. Module: Creating Vector Data, 

 7. Module: Vector Analysis i 

 9. Module: Completing the Analysis, 

publikacije QGIS Training Manual (Thiede 2017), pa se svima onima koji žele da steknu 

dodatna znanja i veštine za rad sa vektorskim podacima u ovom softveru preporučuje čitanje 

te literature i rešavanje opisanih problema i zadataka u QGIS-u. 

Slično kao i za vektorske podatke, niz problema i zadataka koji se odnose na rad sa 

rasterskim podacima, kao i način njihovog rešavanja u softverskom okruženju QGIS-a detaljno 

je opisan u poglavljima:  

 8. Module: Rasters i 

 9. Module: Completing the Analysis, 

publikacije QGIS Training Manual (Thiede 2017), pa se svima onima koji žele da steknu 

dodatna znanja i veštine za rad sa rasterskim podacima u ovom softveru preporučuje čitanje te 

literature i rešavanje opisanih problema i zadataka u QGIS-u. 

 

http://docs.qgis.org/2.18/pdf/en/QGIS-2.18-UserGuide-en.pdf
http://docs.qgis.org/2.18/pdf/en/QGIS-2.18-UserGuide-en.pdf
https://docs.qgis.org/2.18/pdf/en/QGIS-2.18-QGISTrainingManual-en.pdf
https://docs.qgis.org/2.18/pdf/en/QGIS-2.18-QGISTrainingManual-en.pdf

