
5 VEKTORIZACIJA PODATAKA U QGIS OKRUŽENJU 

Cilj ove vežbe je upoznavanje sa naprednim alatima za prikupljanje prostornih podataka 

postupkom manuelne vektorizacije sadržaja sa skeniranih podloga na ekranu monitora u 

okruženju softvera QGIS. 

Pre rada, preporučuje se čitaocu da pročita bar neka od sledećih poglavlja iz publikacije QGIS 

User Guide (QGIS Development Team 2017): 

 Getting Started; 

 QGIS GUI; 

 General Tools; 

 Working with Projections; 

 Managing Data Source; 

 Working with Vector Data (The Vector Properties Dialog; Editing); 

 Plugins (Topology Checker Plugin). 

Tokom izrade biće pokazano i korišćenje SpatiaLite geoprostorne baze podataka za smeštanje 

prostornih podataka o vodovima (koja je format sličan GeoPackage fajl formatu) i ESRI 

Shapefile formata za parcele i zgrade. Sadržaj će biti prikupljan sa skeniranog plana katastra 

vodova. Ukratko će biti opisan i entiteti i njihovi atributi koji čine sadržaj vodovodne mreže, kao 

i osnova (parcele i zgrade). 

Nakon kreiranja sadržaja biće pokazano i kako se korišćenjem topoloških pravila mogu otkriti 

greške u geometriji i topologiji prostornih podataka. 

http://docs.qgis.org/2.18/pdf/en/QGIS-2.18-UserGuide-en.pdf


5.1 Tekst zadatka 

Koristeći QGIS potrebno je izvršiti manuelnu vektorizaciju zadatog sadržaja sa priloženog plana 

katastra vodova. Plan predstavlja skenirani i po propisima georeferencirani katastarski plan 

vodova i podzemnih objekata. Predmet vektorizacije su podzemni vodovi, parcele i objekti 

(zgrade). Klase koje su predmet vektorizacije su: 

 Vod_VM – svi cevovodi primarne i sekundarne mreže snimljeni linijom po sredini 

voda i prikazani na planu plavom bojom; krajnje tačke voda su mesta gde se menja 

zona, dimenzija (presek) ili materijal voda, tačka račvanja voda, vodovodna okna, 

postrojenja i uređaji; 

 Tacka_VM – sve tačke vodovodne mreže u koje se ubrajaju sve prelomne i krajnje 

tačke vodova; 

 Parcela – katastarska parcela kao osnovna katastarska jedinica koja predstavlja deo 

zemljišta određen granicom i označen jedinstvenom oznakom na nivou katastarske 

opštine; 

 Objekat – deo parcele pod zgradom, čemu pripadaju i svi prateći delovi objekta 

(stepeništa, nadstrešnice, terase itd) samo ukoliko na granici između delova objekta 

postoji znak pripadnosti (slovna oznaka Z). 

U nastavku sledi opis sadržaja koji treba vektorizovati sa planova. 

Vodovodna mreža  

Vod_VM – vodovi vodovodne mreže kao polilinije sa sledećim atributima: 

 DPKVID – jedinstveni numerički identifikator voda; 

 Oznaka_voda – alfanumerička oznaka voda; 

 Datum – alfanumeričks oznaka datuma digitalizacije. 

Tacka_VM – tačke vodovodne mreže kao entitete tipa tačka sa sledećim atributima: 

 DPKVID – jedinstveni numerički identifikator tačke voda; 

 TK_KOD – alfanumerička šifra topografskog simbola tačke; 

 Kota_terena – realna numerička vrednost apsolutne visine kote terena u tački; 

 Kota_voda – realna numerička vrednost apsolutne visine kote voda u tački. 

Digitalni katastarski plan 

Parcela – zatvoreni poligoni sa sledećim atributima: 



 ID_Parcele – numerički tip atributa (celobrojne vrednosti koje počinju od 1); 

 Oznaka_parcele – alfanumerički tip atributa ili dva atributa BrojParcele i PodBroj 

1256/6 kao numerički tip atributa 

Objekat – zatvoreni poligoni sa sledećim atributima: 

 ID_Objekta – numerički tip atributa (celobrojne vrednosti koje počinju od 1); 

 Kucni_broj – alfanumerički tip atributa; (5a,5b) 

 Sifra_ulice – numerički tip atributa (na osnovu naziva ulica na planu definisati 

šifarnik naziva ulica sa obaveznim poljima šifra ulice i naziv ulice). 

Tokom vektorizacije voditi računa da se izvrši topološko povezivanje (tzv. snapovanje) u skladu 

sa propisanim topološkim odnosima između entiteta koji su predmet vektorizacije. Sledeći 

topološki odnosi moraju biti poštovani tokom vektorizacije: 

 krajnje i prelomne tačke klase Vod_VM moraju da se poklapaju sa tačkama iz klase 

Tacka_VM; 

 poligoni klase Parcela ne smeju da se preklapaju; 

 između poligona klase Parcela ne sme biti praznina; 

 poligoni klase Objekat ne smeju da se preklapaju; 

 između poligona klase Objekat ne sme biti praznina; 

Nakon izvršene vektorizacije potrebno je izvršiti stilizaciju prikaza i oznaka entiteta na sledeći 

način: 

 Vod_VM – u boji sa plana i prikazanim oznakama vodova; 

 Tacka_VM – odgovarajućim vektorskim simbolom iste veličine kao i na planu i 

oznakama kota terena i kota voda slično kao na planu; 

 Parcele – u svetlo zelenoj boji sa crnim granicama parcele i crnim oznakama 

parcela; 

 Objekti – u svetlo plavoj boji sa tamno plavim granicama i tamno plavim kućnim 

brojem. 



5.2 Podaci neophodni za izradu zadatka 

Podaci neophodni za izradu zadatka dati su u odgovarajućoj pratećoj ZIP datoteci, i to su: 

 skenirani plan u rasterskom formatu (JPEG2000); 

 digitalni topografski ključ - Prilog 1; 

 topografski simbol vodomera u SVG formatu. 

5.3 Postupak izrade 

Korak 1: Pokretanje QGIS-a i kreiranje novog projekta 

Pokrenuti QGIS softverski paket dvoklikom na odgovarajuću ikonicu. Ukoliko ikonica nije 

kreirana na radnoj površini računara (engl. Desktop), program se može pokrenuti i sa lokacije 

gde je instaliran. Po podrazumevanim podešavanjima, izvršna datoteka će se nalaziti na putanji 

"C:\Program Files\QGIS 3.16\bin". Potrebno je sačuvati QGIS projekat, što se vrši opcijom 

Project → Save as, gde je potrebno definisati lokaciju na računaru gde će projekat biti sačuvan i 

njegovo ime („ImePrezime_Vektorizacija.qgz“). 

 

 

Napomena: 

Za sve podatke koji će biti korišćeni u ovom zadatku potrebno je definisati 

parametre projekcije zadate sa predefinisanim koordinatnim sistemom CRS - 

MGI 1901 / Balkans zone 7 (EPSG:3909). 

Napomena: 

Poželjno je povremeno komandom File → Save snimiti QGIS projekat kako bi se 

sačuvale promene i prikupljeni podaci u slučaju nepredviđenih okolnosti (greške 

programa, nestanak struje i sl). 



Korak 2: Učitavanje rasterskog plana 

U prethodno kreirani QGIS projekat učitati priloženi rasterski plan PlanVodova.jp2 opcijom 

Layer → Add Layer → Add Raster Layer. 

Korak 3: Kreiranje SpatiaLite baze podataka i ESRI Shapefile-ova 

U skladu sa tekstom zadatka, potrebno je kreirati bazu podataka u SpatiaLite formatu 

pokretanjem dijaloga Layer → Create Layer → New SpatiaLite Layer.. i klikom na Database 

dugme  (Create a new SpatiaLite database). Bazi dodeliti naziv ImePrezime_Vodovod.sqlite 

u željenom folderu. U okviru ovog dijalog prozora (Slika 5.1) definišu se vektorski slojevi koji 

će biti smešteni u toj bazi. 

  

Slika 5.1. Dijalog prozor za kreiranje SpatiaLite baze podataka i dodelu atributa kreiranim vektorskim 

slojevima 

Svakom kreiranom vektorskom sloju je istovremeno moguće dodavati atribute, a iste je moguće 

definisati i kasnije, posle kreiranja slojeva. 

U prethodno formiranoj bazi podataka u skladu sa tekstom zadatka potrebno je kreirati četiri 

vektorska sloja sledećih karakteristika:  

 Vod_VM (tip Line); 

 Tacka_VM (tip Point); 



Posle toga formirati dva vektorska sloja u vidu Shapefile-ova pokretanjem komande Layer → 

Create Layer → New Shapefile Layer.. 

 

Slika 5.2. Dijalog prozor za kreiranje SpatiaLite baze podataka i dodelu atributa kreiranim vektorskim 

slojevima 

 Parcele (tip Polygon);  

 Objekti (tip Polygon).  

Prilikom kreiranja vektorskih slojeva treba dodeliti projekciju MGI 1901 / Balkans zone 7 

(EPSG:3909) i atribute kao što je zadato u tabeli ispod (Tabela 5.1). 

Tabela 5.1. Atributi vektorskih slojeva u bazi 

Tabela Naziv atributa Tip atributa Widget 

Vod_VM 
DPKVID Integer (Whole number) Text Edit 

Oznaka_voda Text Text Edit 

Tacka_VM 

DPKVID Integer (Whole number) Text Edit 

TK_KOD Text Value Map 

Kota_terena Real Text Edit 

Kota_voda Real Text Edit 



Parcele 
ID_Parcele Integer (Whole number) Text Edit 

OznakaParc Text Text Edit 

Objekti 

ID_Objekta Integer (Whole number) Text Edit 

KucniBroj Text Text Edit 

SifraUlice Integer (Whole number) Value Map 

Nakon kreiranja vektorskih slojeva potrebno je definisati Widget-e u okviru svakog polja 

atributa. Widget-i predstavljaju definisanje forme atributa radi unosa i validacije podataka preko 

korisničke forme. Ovo se vrši tako što se otvori Properties vektorskog sloja i odabere kartica 

Attributes Form sa leve strane. Zatim se selekcijom kreiranog atributa (Fields) u delu Widget 

Type bira tip widget-a. 

Za atribut SifraUlice kod sloja Objekti formirati šifarnik ulica pregledom postojećih naziva ulica 

nanetih na plan vodova i upisati isti u odgovarajuću tabelu dijaloga Value Map. Za sve atribute 

pkuid najbolje definisati Widget - Hidden. 

 

Slika 5.3. Definisanje widget-a Value Map atributa SifraUlice vektorskog sloja Objekti 



Kreirati i zaseban šifarnik u vidu CSV fajla za atribut TK_KOD (simbol topografskog ključa) na 

osnovu dokumenta „Digitalni topografski ključ - Prilog 1“. U datom prilogu u vidu tabele 

predstavljeni su topografski simboli sa njihovim rednim brojem, službenom šifrom, znakom, 

opisom oznake itd. Šifarnik koji treba da se definiše treba da bude podskup ovog priloga i treba 

da sadrži vrednosti atributa Šifra znaka i Opis znaka iz Digitalnog topografskog ključa i to samo 

za znakove od interesa za ovaj zadatak. Znakovi od kojih treba definisati šifarnik (znakovi koje 

treba pronaći u Digitalnom topografskom ključu) su znakovi sledećih opisa znakova:  

 vodomer; 

 nadzemni hidrant bez zatvarača; 

 nadzemni hidrant sa zatvaračem; 

 vodovodni priključak sa ogrlicom;  

 detaljna tačka vodovodne mreže.  

Za razliku od prethodnog šifarnika, ovaj je obimniji pa ga je lakše formirati u MS Excel-u ili 

Notepad-u pa onda sačuvati kao CSV fajl. U QGIS tabelarni podaci se učitavaju korišćenjem 

komande Layer → Add Layer →  Add Delimited Text Layer (Slika 5.4), a onda se povezuju sa 

widget-om TK_KOD vektorskog sloja Tacka_VM preko Value Relation (Slika 5.5). 

 

Slika 5.4. Učitavanje šifarnika u vidu CSV-a za atribut TK_KOD 

 



 

Slika 5.5. Povezivanje šifarnika kao Value Relation za atribut TK_KOD sloja Tacka_VM 

Treba pomenuti da se šifarik u CSV formatu može uvesti od spolja kad se koristi widget Value 

Map tako što se klikne na  dugme Load Data from CSV File i pokaže na šifarnik u CSV formatu. 

Na taj način se zaobilazi postupak učitavanja šifarnika kao tabele u okviru slojeva QGIS-a kad se 

koristi opcija Value Relation. 

 

Korak 5: Manuelna digitalizacija sadržaja 

Nakon prethodne pripreme sledi manuelna digitalizacija definisanog sadržaja. Kao prvi korak 

vizuelnim pregledom rasterskog plana treba odabrati 5 susednih parcela, a koje sadrže nekoliko 

objekata, sa kojih će se vršiti digitalizacija parcela i objekata. 

Napomena: 

Treba voditi računa da se vektorski slojevi iscrtavaju preko plana vodova - rastera 

(podesiti redosled iscrtavanja slojeva). 



Prvo je potrebno izvršiti digitalizaciju objekata, zatim parcela, pa vodova i tačaka vodovodne 

mreže na način kako je to objašnjeno u narednim koracima. Generalno, formiranje novih entiteta 

treba uraditi iz dva koraka: 

1. formiranje geometrije; 

2. unos atributa. 

Proces kreiranje entiteta u okviru sloja počinje desnim klikom na sloj iz spiska slojeva i 

odabirom opcije  Toggle Editing. Ovim postupkom, omogućene su izmene sadržaja sloja i u 

okviru njega mogu se kreirati novi entiteti i/ili menjati postojeći. Zatim kliknuti na ikonicu Add 

Feature (meni Edit → Add Feature) i obeležiti teme/na objekta. Desnim klikom se završava 

kreiranje geometrije, nakon čega se otvara novi prozor za dodelu atributa kreiranom entitetu 

(Slika 5.6). 

 

Slika 5.6. Primer za unos atributa za entitet klase Tacka_VM  

 

 

Napomena: 

Vektorizaciju treba izvršiti sa odgovarajućim uvećanjem sadržaja na ekranu 

vodeći računa da se ne naruši tačnost, tj. da se nedvosmisleno vidi prelomna 

tačka na liniji i da se može precizno izmeriti njena pozicija. 

 

Napomena: 

Tokom digitalizacije (kada je aktivna funkcija Add feature) moguće je pomeranje 

prikaza sadržaja na ekranu pritiskanjem tastera strelica na tastaturi ili 

pomeranjem miša dok je pritisnut SPACE taster na tastaturi. 

  



Korak 6: Digitalizacija entiteta klase Objekat 

Objekte treba formirati kao zatvorene poligone unutar sloja Objekti, nezavisno za svaki objekat. 

Nakon formiranja geometrije potrebno je uneti vrednost za atribut Kucni_broj (broj unutar 

objekta koji je okrenut ka ulici) i odabrati vrednost atributa Sifra_ulice na osnovu naziva ulice, 

tj. punog naziva ulice iz definisanog šifarnika. 

Korak 7: Digitalizacija entiteta klase Parcela 

Parcele treba formirati kao zatvorene poligone precizno digitalizujući granicu parcele tako što se 

precizno definišu sve prelomne tačke granice. Tokom digitalizacije treba voditi računa o tome da 

se na mestima gde je već izvršena digitalizacija susednih parcela koristi opcija Snap. Potrebno je 

podesiti opciju snapovanja za sve slojeve u kojima je ova funkcionalnost neophodna kod 

vektorizacije. Snapovanje se aktivira iz menija Project → Snapping Options. Prvo omogućiti 

snapovanje klikom na dugme sa prikazanim magnetom  - Enable Snapping, aktivno je kad je 

u boji. Na raspolaganju je više načina definisanja snapovanja (Snapping mode), pri čemu je 

Advanced Configuration najizražajniji i omogućava podešavanja za svaki sloj pojedinačno (Slika 

5.7), a na raspolaganju je i definisanje generalnih pravila snapovanja za trenutno aktivni sloj 

(Active Layer) ili za sve vidljive slojeve (All Layers).  

 

Slika 5.7. Podešavanja snapovanja za slojeve 

Ovde je potrebno naglasiti da je po podrazumevanim podešavanjima omogućeno snapovanje na 

temena i linije entiteta (to vertex and segment), ali prilikom digitalizacije sadržaja planova 

potrebno je koristiti snapovanje samo na temena (vertex). Treba odabrati radijus tolerancije 

snapovanja koji će najviše odgovarati za određeni nivo uvećanja prikaza sadržaja. Ukoliko se 

kursor pozicionira unutar definisanog radijusa od temena entiteta, operateru će biti prikazano 

mesto kreiranja novog temena u vidu ljubičastog krstića. 

Nakon formiranja geometrije, potrebno je uneti vrednost za atribut oznaka parcele koji je 

prikazan za tu parcelu na planu (na primer, 123/12). Ako se koristi većina istih vrednosti atributa 

za novi entitet u odnosu na prethodni, bilo bi korisno uključiti opciju Reuse last entered attribute 

values koja se pokreće preko menija Settings → Options, u kartici Digitizing (Slika 5.8). 



  

Slika 5.8. Podešavanja snapovanja za slojeve 

Korak 8: Digitalizacija entiteta klase Vod_VM 

Od svih kartiranih podzemnih vodova potrebno je digitalizovati podzemne vodove vodovodne 

mreže (prikazano plavom bojom na planu). Podzemne vodove treba formirati kao polilinije. 

Poliliniju jednog voda čini niz segmenata linija definisanih tačkama preloma voda od početne do 

krajnje tačke voda. Na koji način se definiše jedan vod, tj. koji je princip podele svih kartiranih 

vodova na polilinije dato je u definiciji klase Vod_VM u okviru teksta zadatka.  



  

Slika 5.9. Primeri krajnjih tačaka polilinija vodova (zaokruženo crveno) 

Tačke na primarnim i sekundarnim vodovima koje odvajaju priključke ka domaćinstvima ne 

treba tretirati kao čvorove tj. krajeve polilinija vodova ukoliko to nisu po definiciji, već kao 

prelomne tačke vodova. Ukrštanja vodova koji su na planu prikazani topografskim simbolom  

nije potrebno digitalizovati kao prelomnu ili krajnju tačku voda. 

Za jedinstven identifikator (atribut DPKVID) potrebno je uneti proizvoljnu celobrojnu 

numeričku vrednost. Za oznaku voda (atribut Oznaka_voda) kao vrednost je potrebno uneti 

tekstualnu oznaku sa voda ukoliko postoji ucrtana na planu. U protivnom ovo polje ostaviti 

prazno. 

Korak 9: Digitalizacija entiteta klase Tacka_VM 

Referentnu tačku ovog entiteta čini centar topografskog simbola na planu. Za sve prelomne i 

krajnje tačke vodova potrebno je kreirati po jednu korespondentnu tačku. Geometrija Tacka_VM 

treba da se poklapa sa geometrijom prelomnih i krajnjih tačaka vodova, što znači da prilikom 

vektorizacije Tacka_VM treba koristiti snapovanje.  

Za jedinstven identifikator (atribut DPKVID) unosi se proizvoljna celobrojna numerička 

vrednost. Da se ne bi stalno unosila nova vrednost i pamtila prethodna, moguće je na kraju 

digitalizacije preuzeti vrednosti ID-eva od atributa pkuid koji se automatski formira kad se kreira 

novi vektorski sloj. 

Kao vrednost atributa TK_KOD unosi se odgovarajuća vrednost na osnovu izgleda topografskog 

simbola tačke na planu, a u skladu sa prilogom 1 digitalnog topografskog ključa. Ukoliko se 

prilikom digitalizacije naiđe na slučaj da je tačka na planu predstavljena topografskim simbolom 

koji nije nijedan od četiri definisana u šifarniku atributa TK_KOD, dodeliti joj vrednost 

„Detaljna tačka vodovodne mreže“.  

Za vrednosti atributa Kota_terena i Kota_voda uzimaju se vrednosti sa plana (Slika 5.10). 

Gornja vrednost (vrednost iznad linije) predstavlja kotu terena, a donja kotu voda. Ukoliko su na 

planu ispisane tri vrednosti jedna ispod druge, za kotu terena uzima se gornja, a za kotu voda 



srednja vrednost. Ukoliko je ispisana samo jedna kota, onda se na osnovu pozicije u odnosu na 

liniju određuje da li se radi o koti terena ili koti voda i to tako što vrednost iznad linije 

predstavlja kotu terena, a vrednost ispod linije predstavlja kotu voda. 

  

Slika 5.10. Primeri kota na planu 

Na levoj slici vrednost 88.21 predstavlja kotu terena, a vrednost 87.57 predstavlja kotu voda. Na 

slici desno vrednost 88.47 predstavlja kotu terena, a vrednost 87.92 predstavlja kotu voda. 



 

 

Slika 5.11. Primeri entiteta klase Tacka_VM koje je potrebno kreirati 

(redom: vodomer; vodovodni priključak sa ogrlicom; detaljna tačka vodovodne mreže) 

Korak 10: Stilizacija prikaza i oznaka digitalizovanih entiteta 

U okviru ovog koraka, potrebno je podesiti prikaz kreiranih geometrijskih entiteta i oznaka (engl. 

labels) u skladu sa zadatkom, a vodeći se uputstvima iz prethodnih vežbi.  

Stilizaciju prikaza i oznaka entiteta potrebno je izvršiti na sledeći način: 

 Vod_VM – u boji sa plana i prikazanim oznakama vodova; 



 Tacka_VM – odgovarajućim vektorskim simbolom iste veličine kao i na planu i 

oznakama kota terena i kota voda slično kao na planu; 

 Parcele – u svetlo zelenoj boji sa crnim granicama parcele i crnim oznakama 

parcela; 

 Objekti – u svetlo plavoj boji sa tamno plavim granicama i tamno plavim kućnim 

brojem. 

 

Za prikaz sadržaja vektorskog sloja Tacka_VM potrebno je podesiti Rule-based stilizaciju nad 

atributom TK_KOD u meniju Style ovog sloja. 

 

Slika 5.12. Stilizacija Tacka_VM vektorskog sloja 

 

Izgled simbola tačaka dat je u prilogu 1 digitalnog topografskog ključa. U zavisnosti od 

vrednosti atributa TK_KOD dodeliti postojeće simbole koji se već nalaze u biblioteci simbola 

QGIS-a. Za detaljnu tačku vodovodne mreže prilikom definisanja simbola potrebno je poslužiti 

se Simple marker opcijom i kombinacijom jednostavnih primitiva kreirati odgovarajuće simbole. 

Treba uvideti da je simbol vodovodnog priključka sa ogrlicom sastavljen od dva preklopljena 

kruga od kojih je gornji isti kao i detaljna tačka, a donji krug sa belom unutrašnjošću i plavom 

ivicom. Na ovaj način mogu se kreirati razni simboli kombinacijom postojećih, podešavanjem 

njihovog redosleda iscrtavanja i transparentnosti (Slika 5.13). 

Napomena: 

Obratiti pažnju na razliku između prikaza definisanog preko point-a i  

map units-a! 

 



 

 

 

Slika 5.13. Primer kreiranja simbola za vodovodni priključak sa ogrlicom 

Za simbol koji reprezentuje vodomer nije pronađen odgovarajući iz postojeće biblioteke, niti ga 

je moguće kreirati kombinacijom jednostavnih primitiva. Umesto toga, simbol vodomera je 

iscrtan u softveru Inkscape, sačuvan u formatu SVG (Scalable Vector Graphics) i priložen sa 

ostalim ulaznim podacima. Tako kreiran simbol je moguće učitati u QGIS i iskoristiti za prikaz 

određenog entiteta. Slika 5.14 sadrži prikaz dijaloga sa podešavanjima za definisanje ovog 

Napomena: 

Voditi računa koje se jedinice koriste za veličinu simbola, o boji simbola kao i o 

dimenzijama, kako bi se što vernije predstavili oblici prikazani na planu. 

 



simbola u QGIS -u, gde je za Symbol layer type potrebno odabrati SVG marker, a zatim pokazati 

putanju na pomenutu SVG datoteku. 

 

Slika 5.14. Podešavanja simbola za vodomer 



Za istovremeni prikaz oznaka (engl. label) kota terena i kota voda potrebno je koristiti opciju 

Expression dialog (poziv na ikonicu  u dijalogu Layer properties → Labels). Na ovaj način 

omogućeno je kreiranje oznake kao rezultata složene funkcije. Primer kreirane oznake za kote 

vodova prikazan je na slici ispod (Slika 5.15). 

 

Slika 5.15. Složeni izraz za definisanje oznake kote voda 

U prethodnoj slici se uzima vrednost polja Kota_terena i pretvara u string (niz karaktera, 

tekstualni tip podataka), potom se operatorom || na to dodaje novi string "\n" koji predstavlja 

prelazak u novi red. Zatim se na takav složeni string dodaje "--------", što bi trebalo da zameni 

horizontalnu liniju između dve kote. Nakon toga se opet u novom redu ("\n") vrednost polja Kota 

voda pretvori u string. 

tostring("Kota_terena")  ||  '\n'  ||  '-------' || '\n'  ||  tostring( "Kota_voda" ) 

 

Za kreiranu oznaku, dodatno je potrebno definisati boju prikaza kota, ali i visinu i poravnanje u 

Formatting delu na sledeći način: 

 Line height – 0.50 line; 

 Alignment – Center. 

Rezultat prethodnih podešavanja bi trebalo da izgleda kao na primeru sa sledeće slike (Slika 

5.16). 

Dodatni zadatak: 

Proučite ostale funkcije koje su date na raspolaganju u Expression dialog 

prozoru. Kada se izabere funkcija iz liste Function list u desnom delu dijaloga 

dobije se objašnjenje i opis rada funkcije. 



 

Slika 5.16. Primer oznake kote 

Korak 11: Validacija topologije digitalizovanih sadržaja 

Validacija topologije kreiranih entiteta se pokreće iz menija: Vector → Topology Checker → 

Topology checker. Ukoliko nema ove komande potrebno ju je pokrenuti iz menija Plugins. 

Klikom na dugme Configure prikazuje se dijalog za definisanje topoloških pravila koje treba 

proveriti. Treba definisati topološka pravila kao na sledećoj slici (Slika 5.17). 

 

Slika 5.17. Definisana topološka pravila 

Nakon što su pravila definisana i kompletan sadržaj digitalizovan, potrebno je aktivirati proveru 

topologije klikom na dugme Validate All. 

Ukoliko postoje kreirani entiteti koji su definisani suprotno uspostavljenim pravilima, potrebno 

je klikom na svaku od grešaka pozicionirati se na nju i otkloniti je korišćenjem alata za izmenu 

entiteta. Nakon što su sve greške otklonjene, komandom File → Save treba snimiti konačni 

QGIS projekat. 



Korak 12: Formiranje karte sa grafičkim prikazom poligona opština i drugim 

elementima karte (pravac severa, legenda, okvir itd.) 

U ovom delu potrebno je formirati kartu na osnovu učitanih prostornih podataka u QGIS-u. 

Korišćenjem različitih selekcija entiteta i upita izvršenih nad atributima moguće je postaviti 

posebnu stilizaciju učitanog sadržaja i definisati legendu koja objašnjava šta koja boja poligona 

predstavlja. 

Karta u QGIS-u se formira pokretnjem Print Layout-a (meni Project → New Print Layout). U 

iskačućem dijalogu potrebno je zadati naziv novog Print Layout-a koji će biti sačuvan zajedno sa 

QGIS projektom. 

Klikom na ikonicu Add Map  vrši se prikaz učitanih prostornih podataka iz radnog 

okruženja QGIS. U okviru palete alatki sa leve strane moguće je izvršiti definisanje legende 

karte (Add Legend - ), kreiranje razmernika (Add Scale Bar ), dodavanje različitih 

geometrijskih primitiva gde trougao može poslužiti kao pravac severa ( Add Shape - ) i 

pisanje teksta (Add Label ) kao i ubacivanje slika (Add Picture - ). 

Sa desne strane se nalazi kartica Item properties u okviru koje se vrši formatiranje ovih 

elemenata karte kao i uključivanje drugih (ukoliko se selektuje pozadina karte može se uključiti 

prikaz okvira karte – Frame. Npr. za legendu u okviru Item properties treba prvo selektovati 

ubačenu  legendu, zatim deštiklirati opciju Auto Update i klikom na dugme  ukloniti slojeve 

koje nije potrebno prikazati u legendi. 

Pokretanjem alatke Add Attribute Table ( ), može se kreirati karta sa izveštajem izvedenih iz 

tabele atributa i prikaz ograničiti na osnovu selekcije. Korišćenjem Move Item Content ikonice     

( ) postiže se pomeranje i zumiranje prikaza unutar karte. 

 


